Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163114

Summary: python script crashes on attempt to submit update
Product: [Retired] Fedora Infrastructure Reporter: Tom Lane <tgl>
Component: update systemAssignee: Luke Macken <lmacken>
Status: CLOSED CURRENTRELEASE QA Contact: Bill Nottingham <notting>
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: hhorak, notting, pfrields, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-13 00:52:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tom Lane 2005-07-13 00:10:34 UTC
Description of problem:
Got as far as update summary page:
https://porkchop.devel.redhat.com/fedora-updates/show.py?
pkg=mysql-4.1.12-2.FC4.1&update=testing

press "submit to release team for pushing", get
https://porkchop.devel.redhat.com/fedora-updates/submit.py?pkg=mysql-4.1.12-2.FC4.1
Submitting to Release Team...
Mod_python error: "PythonHandler mod_python.publisher" Traceback (most recent call last): File "/usr/
src/build/513032-i386/install/usr/lib/python2.2/site-packages/mod_python/apache.py", line 332, in 
HandlerDispatch File "/usr/src/build/513032-i386/install/usr/lib/python2.2/site-packages/
mod_python/publisher.py", line 199, in handler File "/mnt/redhat/fedora-updates/submit.py", line 80, 
in index req.write("
" % AttributeError: ValueError instance has no attribute 'smtp_error'


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Since I've not used this system before, it's entirely likely I did something wrong ... but this isn't a real 
helpful error message.

Comment 1 Luke Macken 2005-07-13 00:52:21 UTC
The problem is now fixed, and I re-submitted your update for pushing.  Thanks
for the report.