Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 163027

Summary: FC4's perl-DBD-Pg fails to detect PostgreSQL version for PostgreSQL 8
Product: [Fedora] Fedora Reporter: Emmanuel Seyman <emmanuel>
Component: perl-DBD-PgAssignee: Warren Togami <wtogami>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: mkanat, perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-03 16:08:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Updates perl-DBD-Pg's spec file to v1.43 none

Description Emmanuel Seyman 2005-07-12 11:47:30 UTC
Description of problem:
When installing the current CVS version of Bugzilla on FC4, selecting postgresql
as the database and running the checksetup script to configure it ends with:

Checking for      PostgreSQL (v7.03.0000)
Your PostgreSQL v00.00.0000 is too old.
   Bugzilla requires version 7.03.0000 or later of PostgreSQL.
   Please download and install a newer version.

This is due to a bug in DBD-Pg which gives the wrong version numbre of
postgresql. It's fixed upstream in 1.43

Version-Release number of selected component (if applicable):
1.41-2

How reproducible:
always

Steps to Reproduce:
1. checkout current CVS version of Bugzilla
2. run checksetup and edit localconfig to use postgresql as a database
3. run checksetup a second time
  
Actual results:
Checksetup ends with:

Checking for      PostgreSQL (v7.03.0000)
Your PostgreSQL v00.00.0000 is too old.
   Bugzilla requires version 7.03.0000 or later of PostgreSQL.
   Please download and install a newer version.

Expected results:
The correct version of postgresql should be reported (v08.00.0300 in FC4's case)

Additional info:
I've updated the .spec file to build DBD-Pg 1.43. Diff attached.

Comment 1 Emmanuel Seyman 2005-07-12 11:47:31 UTC
Created attachment 116650 [details]
Updates perl-DBD-Pg's spec file to v1.43

Comment 2 Jose Pedro Oliveira 2005-07-28 02:49:55 UTC
Seyman,

perl-DBD-Pg 1.43 is in rawhide since the end of June and it is expected to be
released as an FC4 update (see bugzilla entry 156840).

Can you the rawhide version with bugzilla and post the results here?

Thanks in advance,
jpo


Comment 3 Emmanuel Seyman 2005-07-28 12:33:40 UTC
(In reply to comment #2)
>
> Seyman,

Ugh. Emmanuel, please.

> Can you the rawhide version with bugzilla and post the results here?

Installed. This fixes all the problems I had with 1.41