Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162902

Summary: Switching between static and dhcp leaves static settings for gateway
Product: [Fedora] Fedora Reporter: Darren Fulton <dfulton>
Component: system-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: coleman
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-05-19 10:35:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 162648    
Bug Blocks:    

Description Darren Fulton 2005-07-11 15:35:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
If ethernet interface is configured with static network settings in the ifcfg-eth$ file and then switched to DHCP using system-config-network, it leaves the network settings in the ifcfg-eth$ file and just changes BOOTPROTO=dhcp.  That causes the interface to get network settings via DHCP, when the interface is activated, with the exception of the gateway.  If the gateway entry is not set to blank, the interface will not have get a gateway via DHCP.  If the static gateway setting that was left behind is removed, the interface gets a static route added to the gateway, which is desirable.

Version-Release number of selected component (if applicable):
system-config-network-1.3.26-1

How reproducible:
Always

Steps to Reproduce:
1. configure a network interface with valid static settings using system-config-networking
2. modify ifcfg-eth$ to include a gateway
3. activate the interface
4. modify interface to get settings via dhcp on a network with a good dhcp server
5.  reactivate the interface.  Interface will receive network settings from DHCP with the exception of the gateway.

Actual Results:  If the gateway entry is not set to blank, the interface will not have get a gateway via DHCP.

Expected Results:  If the static gateway setting that was left behind is removed, the interface gets a static route added to the gateway, which is desirable.

Additional info:

This behavior would be very confusing to most people.

Comment 1 Weston Schmidt 2005-07-28 04:40:08 UTC
Hi,  I just found this exact bug with my system.  I spent half of last night and
a few hours today trying to figure out what was wrong with my NAT server until
my wife told me that she was able to communicate with the outside world.

Is this project's repository externally available somewhere?  I am interested to
see if I can fix this & submit the patch.

Thanks,
Weston Schmidt

Comment 2 Sean Coleman 2006-03-14 07:25:59 UTC
It would be nice if system-config-network removed all entries in
the ifcfg-* file relating to the old static IP information to make
the config file look clean

Comment 3 Harald Hoyer 2006-03-14 07:36:55 UTC
on the other hand, people want to switch between static and dynamic without
entering all information again... :-/

Comment 4 Harald Hoyer 2006-05-19 10:35:12 UTC

*** This bug has been marked as a duplicate of 149780 ***