Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162866

Summary: Error message "No provider available for protocol 'file'"
Product: [Fedora] Fedora Reporter: Ivo Sarak <ivo>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED INSUFFICIENT_DATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: mcepl, mcepl
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-02 17:06:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ivo Sarak 2005-07-10 20:30:51 UTC
Description of problem:
Every time I send an e-mail I get message about missing "provider for protocol
'file'".

Version-Release number of selected component (if applicable):
evolution-2.2.2-5

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade FC4 from FC3;
2. Try to send an e-mail with evolution;
  
Actual results:

"Error while performing operation.

Failed to append to file:///home/ivo/evolution/local/Sent: No provider available
for protocol `file'
Appending to local `Sent' folder instead.."

Expected results:
E-mail sent and no errors reported.

Additional info:

How to fix the issue?

Comment 1 Ivo Sarak 2005-07-10 20:49:51 UTC
I wonder where why it is looking for ~/evolution directory as all files are in
~/.evolution directory?

Comment 2 Ron Bergeron 2005-07-13 15:04:43 UTC
I had the same problem. I'm not sure if this is a fix or a workaround, but:

Edit -> Preferences
Select an account name
Edit -> Defaults
Change "Drafts Folder" to "Drafts"
Change "Sent Messages Folder" to "Sent"
OK -> Close

Send a message to test it out. It worked for me.

Comment 3 Ivo Sarak 2005-07-13 19:30:11 UTC
Thanks. It worked for me, too.

Comment 4 Dave Malcolm 2005-07-19 16:30:10 UTC
Good to hear that there's a workaround.

Is your home directory shared with another installation perhaps?  Was this
machine upgraded from FC2 in the past.  Did the upgrade from FC3->FC4 work OK? 
Comment #1 seems relevant here; it ought to be in the ~/.evolution folder.

Comment 5 Ingo Schaefer 2006-04-12 07:35:51 UTC
Additional Info:

I also had this problem with all my filters defined.

The format of the configuration file has changed and sometime migration does not
work. Several time search->replace in the xml files do the trick.

Regards,
Ingo

Comment 7 Matthew Barnes 2006-12-31 17:02:05 UTC
Does this problem still exist in Fedora Core 6?

Comment 8 Matěj Cepl 2007-08-31 15:23:09 UTC
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.

Comment 9 Matthew Barnes 2007-10-02 17:06:02 UTC
Closing as INSUFFICIENT_DATA.