Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162851

Summary: Installer crashed after I took the core dump
Product: [Fedora] Fedora Reporter: Oded <oded_it>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED WORKSFORME QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-26 03:58:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Oded 2005-07-10 12:56:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)

Description of problem:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 158, in readPackages
    hdrlist = method.readHeaders()
  File "/usr/lib/anaconda/urlinstall.py", line 189, in readHeaders
    hdrString = raw[8:] + url.read(totalSize)
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 393, in read
    s = self._rbuf + self._raw_read(amt)
  File "/usr/lib/python2.4/httplib.py", line 456, in read
    return self._read_chunked(amt)
  File "/usr/lib/python2.4/httplib.py", line 495, in _read_chunked
    chunk_left = int(line, 16)
ValueError: invalid literal for int(): 

Local variables in innermost frame:
i: -1
self: <urlgrabber.keepalive.HTTPResponse instance at 0xb7a7004c>
chunk_left: None
value: 

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I tried to install again but it worked in the second time

Additional info:

Comment 1 Oded 2005-07-10 12:58:26 UTC
It happend when I installed from the site 
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/
After the step I entered root password twice.

Comment 2 Jeremy Katz 2005-07-12 15:14:03 UTC
So this wasn't reproducible?  This looks like an odd little network blip
confusing python.

Comment 3 Oded 2005-07-19 13:07:06 UTC
Could be. I had during the packages installation a network error and when I  
installed the packages again, it was OK.