Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162801

Summary: ia64 boot.img's vmlinuz corrupt
Product: [Fedora] Fedora Reporter: Prarit Bhargava <prarit>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-08 19:00:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Prarit Bhargava 2005-07-08 18:46:49 UTC
Description of problem: 
 
I noticed that the boot.img vmlinuz image did not unpack properly and was 
a different size than expected. 
 
The ia64 build process yields: 
 
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz 
Loading /lib/kbd/keymaps/i386/qwerty/us-acentos.map.gz 
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz 
cannot find package kernel-BOOT in 
path /mnt/redhat/nightly/rawhide-20050708/ia64/Fedora/RPMS 
kernel-BOOT does not exist for ia64 -- using kernel package 
unpacking /mnt/redhat/nightly/rawhide-20050708/ia64/Fedora/RPMS/kernel-2.6.12-1.1422_FC5.ia64.rpm.ia64 
Wrote /tmp/makebootdisk.initrdimage.7107 (6720k compressed) 
cp: writing `/tmp/makebootdisk.tree.7107/vmlinuz': No space left on device 
 
(and continues on) 
 
Version-Release number of selected component (if applicable): 
 
rawhide-20050708 
 
How reproducible: 
 
100% 
 
Steps to Reproduce: 
1.  build installation 
   
Actual results: 
 
Build finishes, but kernel image is corrupt. 
 
Expected results: 
 
Build should fail? -- Jeremy, what do you think? 
 
Additional info: 
 
I'm going to pursue this for ia64.

Comment 1 Jeremy Katz 2005-07-08 19:00:15 UTC
Looks like the size of the boot.img just isn't big enough.  Bumped a bit.