Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162770

Summary: kernel panics with 2.6.12-1.1370_FC3smp but is fine non-smp (mptscsih.ko)
Product: [Fedora] Fedora Reporter: Michael Ditum <mike.ditum>
Component: mkinitrdAssignee: Dave Jones <davej>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: armijn, nathan-redhatbugzilla, pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-21 14:14:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Ditum 2005-07-08 15:37:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I installed the kernel-2.6.12-1.1370_FC3.i686.rpm and kernel-smp-2.6.12-1.1370_FC3.i686.rpm files (from to test the new kernel for my DVB-S Card.

Booting the non-smp one is fine (and my DVB card works great) however if I try to boot the smp kernel I get a kernel panic a little while after an insmod error about mptscsih.ko having an unknown symbol.

This is running on an HP ProLiant ML350 G4 Server (info at

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Get an HP ProLiant ML350 G4
2. Install kernel-smp-2.6.12-1.1370_FC3.i686.rpm
3. Boot smp kernel

Actual Results:  Booting 'Fedora Core (2.6.12-1.1370_FC3smp)'

root (hd0,0)
  Filesystem type is ext2fs, partition type 0x83
  kernel /vmlinuz-2.6.12-1.1370_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    [Linux-bzImage, setup=0x1e00, size=0x17e806]
  initrd /initrd-2.6.12-1.1370_FC3smp.img
    [Linux-initrd @ 0x1fed9000, 0x109cea bytes]

Uncompressing Linux... OK booting the kernel.
pnp: Unable to assign resources to device 00:08
Red Hat nash version 4.1.18 starting
insmod: error inserting '/lib/mptscsih.ko': -1 Unknown symbol in module
Error /bin/insmod exited abnormally!
insmod: error inserting '/lib/dm-mirror.ko': -1 Unknown symbol in module
Error /bin/insmod exited abnormally!
mount: error 6 mounting ext2
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not synching: Attempting to kill init!

Expected Results:  Computer should load drivers correctly and then boot up

Additional info:

I got this same error message when I tried building kernel from source using version. Thought I would try your version to see if it had been fixed.

Comment 1 Dan Carpenter 2005-07-08 20:29:27 UTC
This could be the same thing as bug 160652

Can't hurt to try upgrading you mkinitrd package and retesting.

Comment 2 Michael Ditum 2005-07-11 09:16:57 UTC
Its booting now but I have another problem which is a side effect from this...
just to document...

I updated to mkinitrd from FC4 and that required that I updated to udev 057-3
though I could only find an rpm for udev 058-1 also for FC4 (both were
downloaded from

I then removed the kernel rpm's using -e and then installed them again.

The system now boots fine and seemed to be working ok.

I assume when you release the new kernel you will create new packages of
mkinitrd and udev for FC3 as well to fix this 


However my dvb drivers no longer work. They aren't creating the device nodes
when I load the modules. I downgraded mkinitrd and udev back to their original
versions and it works fine now. I assume its a problem with the new version of
udev. The output to /var/log/messages looks exactly the same for both versions
so maybe its just a configuration issue. Only thing that looks slightly suspect
is the line...

Jul 11 09:52:22 bloodhound hal.hotplug[4629]: DEVPATH is not set

but that appears with both versions of udev...

Not sure if I should issue a new bug report or not as I installed an FC4 rpm on
FC3... not exactly something you support.

Thanks for all your help!

Comment 3 Dave Jones 2005-07-15 19:32:24 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 4 Dave Jones 2005-07-15 23:22:07 UTC
note that mixing and matching bits from different releases can sometimes lead to
really obscure bugs, that are particularly awkward to diagnose.  It may be in
your best interest to reinstall with fc4 at some point.

Comment 5 Armijn Hemel 2005-07-16 08:59:52 UTC
I just installed the latest FC3 update (kernel-2.6.12-1.1372_FC3) and I'm seeing
similar errors:

mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not synching: Attempting to kill init!

This only happens when I boot the SMP kernel, the non-smp kernel works just fine.
The machine is a vanilla FC3.

Comment 6 Allen Kistler 2005-07-16 21:09:08 UTC
My experience is similar to Comment #5.  Here's a little more info.

Booting 2.6.11-1.35_FC3smp (which works fine), a slightly expanded console
output looks like this:

Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module
Loading aic79xx.ko module
Creating root device
Mounting root filesystem

Booting 2.6.12-1.1372_FC3smp (broken) looks like this:

Loading scsi_mod.ko module
Loading sd_mod.ko module
SCSI subsystem initialized  [note the different order, significant?]
Loading aic79xx.ko module
Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext2
mount: error 2 mounting none

I've torn the two respective initrds apart (zcat | cpio -idm).
The directories are identical.  The init files are identical.

According to sfdisk, my labels are just fine.

Comment 7 Dan Carpenter 2005-07-16 21:41:04 UTC
Disclaimer:  I don't work for RedHat

I hate to see you guys banging your heads against the wall.

> The issue is that David Howells posted a patch that changed the behaviour of
> kallsyms/insmod/rmmod sometime ago. The patch *is correct* in what it does,
> however, the patch requires that /sbin/sh [in the initrd] must be aware of 
> pid returns by wait().

So basically, you should just be able to unpack your initrd, insert an updated
/bin/sh and package it up again.  

Probably an easier thing is to just downgrade your kernel until a new mkinitrd
package for FC3 is released.

Comment 8 Allen Kistler 2005-07-21 00:41:31 UTC
Perhaps Mike D should change the component to mkinitrd, then, which will let
whoever covers mkinitrd know there's something to do for fc3 and get this bug
out of NEEDINFO status and moving forward.  Dan C's comment seems pretty
convincing.  Anyone disagree?

Comment 9 Michael Ditum 2005-07-21 07:39:35 UTC
I just checked the new 2.6.12-1.1372_FC3smp kernel and it didn't fix the problem
so I'm gonna do as Allen K says and change the component to mkinitrd. Feel free
to change it back if I shouldn't have...

Comment 10 Frank Ch. Eigler 2005-07-21 14:14:42 UTC

*** This bug has been marked as a duplicate of 163437 ***