Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162666

Summary: HP LaserJet 3020 not consistent in XML
Product: [Fedora] Fedora Reporter: Alex Gal <alexander.gal>
Component: foomaticAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: perbjornsson
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-05 11:32:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
/usr/share/foomatic/db/source/printer/HP-LaserJet_3020.xml none

Description Alex Gal 2005-07-07 13:17:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050701 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
The printer is not being autodetected, system-config-printer reports the following:
No match for USB device:
  mfr "Hewlett-Packard"
  model "hp LaserJet 3020"
  desc "Hewlett-Packard LaserJet 3020"
  cmdset "PJL,MLC,BIDI-ECP,PCL,POSTSCRIPT,PCLXL"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.

Version-Release number of selected component (if applicable):
foomatic-3.0.2-19

How reproducible:
Always

Steps to Reproduce:
1. run system-config-printer
2.
3.
  

Additional info:

Comment 1 Tim Waugh 2005-07-07 13:54:55 UTC
Created attachment 116476 [details]
/usr/share/foomatic/db/source/printer/HP-LaserJet_3020.xml

Please save this file and copy it to:

  /usr/share/foomatic/db/source/printer/HP-LaserJet_3020.xml

Does this cause the printer to be automatically selected in the model list?

Comment 2 Alex Gal 2005-07-11 16:19:47 UTC
when I logged in for a first time after installation, a dialog asking to choose
a printer driver was presnted to me with the correct model selected. Although
after confirming the selection nothing happend and system-config-printer still
had no installed printers. And in fact it doesn't show that model in its list at
all. The message above is being shown by system-config-printer even after I've
substituted the original file with the one you provided.

Comment 3 Tim Waugh 2005-07-11 16:30:35 UTC
Please try this as root:

rm -f /var/cache/foomatic/printconf.pickle

Then start system-config-printer again -- does the problem persist?

Comment 4 Alex Gal 2005-07-14 23:08:15 UTC
yes, the problem presists.
One more interesting thing when I run :
"gconftool-2 --recursive-unset /system/printing"
and then reconnect a printer I get a message that application "eggcups" has quit
unexpectedly and when I click "restart application" I get the dialog to choose
the printer with the correct model chosen. As before no priners are added to the
system. I guess that eggcups shoudn't crash like this. Should I file another bug
to "eggcups" ?

Comment 5 Tim Waugh 2005-07-26 10:45:18 UTC
Yes, please *please* do not put more than one issue in a bug report, because it
makes it impossible to track issues individually.

(That command is in no way related to the problem we're trying to solve.)

Comment 6 Tim Waugh 2005-07-26 11:12:41 UTC
Okay, the problem here is that HP-LaserJet_3020 is not referenced by any of its
drivers, and so it is not being loaded at all.

Comment 7 Per Bjornsson 2005-08-19 06:43:19 UTC
I just had the same problem with a LaserJet 3015; it seems it needs the same
fix. After manually importing the PPD (from the Action>Import PPD... menu item)
everything seems to work fine. (I'm pretty sure that it should use the same
drivers so the fix should be the same.)

The error message from system-config-printer is
No match for USB device:
  mfr "Hewlett-Packard"
  model "hp LaserJet 3015"
  desc "Hewlett-Packard LaserJet 3015"
  cmdset "PJL,MLC,BIDI-ECP,PCL,POSTSCRIPT,PCLXL"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.


Comment 8 Tim Waugh 2005-09-05 11:32:20 UTC
Please file a separate report for this.  The original problem is fixed in rawhide.