Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162634

Summary: lowlevellock.h
Product: [Fedora] Fedora Reporter: Jungwoo Ha <habals>
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: low Docs Contact:
Priority: medium    
Version: 4CC: bsingharora, drepper, dwmw2, maxtractor
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.3.90-2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-07 20:50:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jungwoo Ha 2005-07-06 23:31:51 UTC
Description of problem:
From package glibc-headers.i386.2.3.5-10,
/usr/include/bits/stdio-lock.h
This file includes "lowlevellock.h" which is not present anywhere.
I'm having trouble compiling sources require stdio-lock.h

Version-Release number of selected component (if applicable):
FC4
glibc-headers.i386.2.3.5-10 
kernel-smp.i686.2.6.12-1.1387_FC4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

It is obvious this file is missing.

Comment 1 Jakub Jelinek 2005-07-07 08:27:10 UTC
Can you explain what do you need bits/stdio-lock.h for?

Comment 2 Jungwoo Ha 2005-07-07 08:37:47 UTC
I'm compiling GCC-2.95.3 using GCC-4.0.0. 

/prj/src/gcc/gcc-2.95.3/gcc/xgcc -B/prj/src/gcc/gcc-2.95.3/gcc/ -
B/usr/local/i686-pc-linux-gnu/bin/ -c -g -O2 -fvtable-thunks -D_GNU_SOURCE -
fno-implicit-templates -I. -I. -nostdinc++ -D_IO_MTSAFE_IO stdstrbufs.cc
In file included from libio.h:167,
                 from iolibio.h:1,
                 from libioP.h:47,
                 from stdstrbufs.cc:32:
/usr/include/bits/stdio-lock.h:24: lowlevellock.h: No such file or directory
make[1]: *** [stdstrbufs.o] Error 1
make[1]: Leaving directory `/prj/src/gcc/gcc-2.95.3/i686-pc-linux-gnu/libio'
make: *** [all-target-libio] Error 2


Comment 3 Ulrich Drepper 2005-07-07 20:50:00 UTC
The file is definitely never going to be distributed.  It is not part of the API.

Remove the _IO_MTSAFE_IO definition from the command line and do whatever else
is necessary to make this compile without using stdio-lock.h.  This is just a
symptom of using completely obsolete code.

Comment 4 Jakub Jelinek 2005-07-10 20:28:54 UTC
I have changed glibc.spec, so that it installs sysdeps/generic/bits/stdio-lock.h
over the NPTL specific header.  The generic <bits/stdio-lock.h> is what
linuxthreads was using and should work just fine with NPTL as well.

Comment 5 Jakub Jelinek 2005-07-13 11:16:07 UTC
*** Bug 163131 has been marked as a duplicate of this bug. ***

Comment 6 Petr Berka 2005-12-17 19:52:13 UTC
(In reply to comment #4)
> I have changed glibc.spec, so that it installs sysdeps/generic/bits/stdio-lock.h
> over the NPTL specific header.  The generic <bits/stdio-lock.h> is what
> linuxthreads was using and should work just fine with NPTL as well.

Hi.

So, how can I solve this error? I need gcc-2.95.3 to install some application
which needs it and I don't understand what should I do to be successful in
instalation of gcc-2.95.3.

Any help is appreciated. Thanks a lot in advance.

My error:
In file included from ../../../zdroj_gcc/libio/libio.h:167,
                 from ../../../zdroj_gcc/libio/iolibio.h:1,
                 from ../../../zdroj_gcc/libio/libioP.h:47,
                 from ../../../zdroj_gcc/libio/iogetline.c:26:
/usr/include/bits/stdio-lock.h:24: lowlevellock.h: není souborem ani adresáÅem
make[2]: *** [iogetline.o] Error 1
make[2]: Leaving directory `/opt/gcc-2.95.3/i686-pc-linux-gnu/libio'
make[1]: *** [all-target-libio] Error 2
make[1]: Leaving directory `/opt/gcc-2.95.3'
make: *** [bootstrap] Error 2
[root@localhost gcc-2.95.3]#