Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162549

Summary: BackSpace doesn't work in xterm
Product: [Fedora] Fedora Reporter: Noa Resare <noa>
Component: xtermAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-07 19:50:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Noa Resare 2005-07-06 07:42:24 UTC
Description of problem:

When I use xterm instead of gnome-terminal and try to use 'vi' to edit a 
textfile the delete button doesn't delete characters but instead prints ^?

With gnome-terminal this works as expected.

Version-Release number of selected component (if applicable):
xterm-200-6
vim-minimal-6.3.071-3

How reproducible:
always

Steps to Reproduce:
1. start an xterm
2. start 'vi'
3. write something and try to delete it with the BackSpace button
  
Actual results:
A char that looks like ^? is printed (the one that is one character)

Expected results:
the character at the crusor should be deleted

Additional info:
If I ssh into a fc3 box (for which this was not an issue) and run vi it also
exhibits the problem.

LANG is sv_SE.UTF-8
keyboard layout is swedish

Comment 1 Noa Resare 2005-07-06 07:45:28 UTC
Oops. rereading I found that i use the term Delete (which can be mistaken for
the button with the text 'Delete' on it). The key marked 'Delete' doesn't work
either in vi, but the key that I'm referring to above is the one in the upper
right corner of the keyboar with an arrow pointing to the left. Using 'xev' it
seems like that button generates the keysym 'BackSpace'.

Comment 2 Thomas E. Dickey 2005-07-07 18:31:44 UTC
See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160354

Comment 3 Noa Resare 2005-07-07 19:50:02 UTC

*** This bug has been marked as a duplicate of 160354 ***

Comment 4 Fedora Update System 2005-11-07 19:34:02 UTC
From User-Agent: XML-RPC

xterm-205-1.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 5 Fedora Update System 2005-11-14 18:04:57 UTC
From User-Agent: XML-RPC

xterm-205-1.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.