Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162451

Summary: bttv channel tuning broken in 1411
Product: [Fedora] Fedora Reporter: John Ellson <john.ellson>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: pallas, pfrields, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-04 01:03:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg | grep "bttv\|tuner" for kernel 1400 - channel changing OK
none
dmesg | grep 'bttv\|tuner" for kernel 1421 - channel changing broken none

Description John Ellson 2005-07-04 23:57:18 UTC
Description of problem:
tvtime (DAG) worked with kernel-2.6.12-1.1400_FC5, but channel changing
is broken with kernel-2.6.12-1.1411_FC5.   The tuner stays stuck on one channel.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1411_FC5

How reproducible:
100%.  Tried warm and cold reboots.  Same problem.
Downgraded to 2.6.12-1.1400_FC5 and problem goes away.

Steps to Reproduce:
1.tvtime
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John Ellson 2005-07-06 22:07:42 UTC
Same problem with 1421.  I looked at: dmesg | grep "bttv\|tuner"
and the only difference is that 1421 adds:
    tuner 2-0061: All bytes are equal. It is not a TEA5767

I verified that the problem is the same with tvtime-0.9.15-7.x86_64.rpm
from Fedora-Core-4

Comment 2 John Ellson 2005-07-06 22:09:48 UTC
Created attachment 116439 [details]
dmesg | grep "bttv\|tuner" for kernel 1400 - channel changing OK

Comment 3 John Ellson 2005-07-06 22:10:58 UTC
Created attachment 116440 [details]
dmesg | grep 'bttv\|tuner" for kernel 1421 - channel changing broken

Comment 4 Michael Schwendt 2005-07-11 11:02:41 UTC
Also see bug 162595 (tvtime not working on kernel 2.6.12-1.1421_FC5, No signal).

Comment 5 John Ellson 2005-07-11 12:17:01 UTC
Agree with #4. I added a comment to 162595.

Comment 6 Ngo Than 2005-07-11 12:20:01 UTC
*** Bug 162595 has been marked as a duplicate of this bug. ***

Comment 7 John Ellson 2005-10-04 00:21:10 UTC
Seems to be fixed: kernel-2.6.13-1.1589_FC5, tvtime-1.0.1-1