Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 162222

Summary: hplip doesn't support parallel port-connected printers that hpoj did
Product: [Fedora] Fedora Reporter: Alexandre Oliva <oliva>
Component: hplipAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: notting
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://hpinkjet.sourceforge.net/faqs.php
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-05 16:34:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 150221    

Description Alexandre Oliva 2005-06-30 22:10:33 UTC
The HP Inkjet project faq explicitly suggests the use of hpoj for
parallel-connected multi-functional devices like my HP OfficeJet 725.  It's true
that it's old, but it still works pretty well.  Can't we have both hplip, for
newer devices, and hpoj, for older ones?  I don't expect conflicts, since the
latter requires manual configuration.

Comment 1 Alexandre Oliva 2005-07-01 12:29:29 UTC
FWIW, I've installed FC4's hpoj on FC devel, configured it, and now the printer
works again.  The only oddity was that cups really seemed to want an hplip
daemonsto be running, otherwise it would log a message about being unable to
contact an hp daemon, and then the unrelated printer wouldn't work.

Comment 2 Tim Waugh 2005-07-01 14:15:37 UTC
I've removed the Obsoletes: tags for hpoj in hplip.spec, and reinstated PTAL
support in system-config-printer.

How about if the hpoj package is added to Fedora Extras?

Comment 3 Alexandre Oliva 2005-07-01 20:44:34 UTC
Thanks.  hpoj in extras sounds fine, especially if the FC5 installer can pull
stuff from extras.

That said, my first inclination would be to consider something as basic as
supporting parallel printers to be Core material, but then, since ptal requires
manual configuration anyway, I guess there's very little advantage to having it
in Core rather than Extras.

Do you plan on maintaining it in Extras yourself?

Thanks again,

Comment 4 Tim Waugh 2005-07-04 14:24:07 UTC
I hadn't been planning on maintaining it in Extras myself, but was hoping that
someone else might step forward to do it.

Comment 5 Tim Waugh 2005-07-25 09:40:19 UTC
Apparently HPLIP is going to grow parallel port support in the FC5 timeframe.

Comment 6 Alexandre Oliva 2005-11-05 16:34:22 UTC
It did, rawhide can already handle my parallel-connected printer.  Yay!