Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161776

Summary: telnet man page has a formatting problem
Product: Red Hat Enterprise Linux 4 Reporter: David Tonhofer <bughunt>
Component: krb5Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: low Docs Contact:
Priority: medium    
Version: 4.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.3.4-13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-06 13:59:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Tonhofer 2005-06-27 09:15:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Typing 'man telnet' just gives you unformatted garbage like this:

-------------
        .           .          .          .          .          .          .          .          .          .          .          .          .
        .          .          .          .          .          .          .          .          .          .          .TH TELNET 1         .SH
NAME          telnet  &#8722; user interface to the TELNET protocol         .SH SYNOPSIS         .B telnet         [&#8722;8] [&#8722;E] [&#8722;F] [&#8722;K] [&#8722;L] [&#8722;S tos]
[&#8722;X authtype] [&#8722;a] [&#8722;c] [&#8722;d] [&#8722;e escapechar] [&#8722;f] [&#8722;k realm] [&#8722;l user] [&#8722;n tracefile] [&#8722;r] [&#8722;x] [host [port]] The command is used to  communi-
cate  with  another  host  using  the protocol.  If is invoked without the argument, it enters command mode, indicated by its prompt ( In this
-------------

However, the file /usr/share/man/man1/telnet.1.gz looks like properly 
formatted groff, also "less /usr/share/man/man1/telnet.1.gz" automagically
formats everything correctly. 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
n/a
  

Actual Results:  n/a

Expected Results:  n/a

Additional info:

n/a

Comment 1 Harald Hoyer 2005-09-02 15:06:46 UTC
what is the output of:
# man -aw telnet

??

Comment 2 David Tonhofer 2005-09-02 16:04:15 UTC
It might just be that the problem has been fixed. On a RH ES 4 system that
has not be updated in a long time, the problem occurs as described:

# man -aw telnet
/usr/kerberos/man/man1/telnet.1.gz
/usr/share/man/man1/telnet.1.gz
# rpm --query telnet
telnet-0.17-30
# uname -a
Linux foo 2.6.9-5.0.3.ELsmp #1 SMP Mon Feb 14 10:00:21 EST 2005 x86_64 x86_64
x86_64 GNU/Linux

On a recently updated system ,the problem does no longer occur:
# man -aw telnet
/usr/kerberos/man/man1/telnet.1.gz
/usr/share/man/man1/telnet.1.gz
# rpm --query telnet
telnet-0.17-31.EL4.3
# uname -a
Linux bar 2.6.9-11.ELsmp #1 SMP Fri May 20 18:25:30 EDT 2005 x86_64 x86_64
x86_64 GNU/Linux

Comment 3 Harald Hoyer 2005-09-05 05:48:57 UTC
try this:
# man /usr/kerberos/man/man1/telnet.1.gz
# man /usr/share/man/man1/telnet.1.gz

Comment 4 David Tonhofer 2005-09-05 08:51:32 UTC
On the older system where "man telnet" gives unformatted output:

# man /usr/kerberos/man/man1/telnet.1.gz  --> Unformatted
# man /usr/share/man/man1/telnet.1.gz     --> Formatted

Ah-ha. 

($MANPATH is currently
 "/usr/java/jdk/man::/usr/local/apache2/man:/usr/local/mysql/man"
 $LANG on both systems is en_US.UTF-8)

On the newer system where "man telnet" gives formatted output:

# man /usr/kerberos/man/man1/telnet.1.gz  --> Formatted
# man /usr/share/man/man1/telnet.1.gz     --> Formatted

Right. The 'man telnet' page is indeed the kerberos manpage on
both systems as it mentions 'k5login' among others.

Comment 5 Harald Hoyer 2005-09-05 16:09:12 UTC
$ rpm -qf /usr/kerberos/man/man1/telnet.1.gz
krb5-workstation-1.4-3


Comment 6 Nalin Dahyabhai 2005-09-06 13:59:17 UTC
David, I think the update which corrected this for you was
krb5-workstation-1.3.4-13, which incorporated the fix from bug #120618.  Closing
as fixed in current release because an updated system has the fix.