Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161698

Summary: not matching i386 and x86_64 versions
Product: [Fedora] Fedora Reporter: Rudolf Kastl <che666>
Component: gnome-themes-extrasAssignee: Phillip Compton <compton>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: matthias
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-08-08 19:15:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rudolf Kastl 2005-06-26 00:48:06 UTC
Description of problem:
well the versions dont match (and i know they cant) so actually the i386 version
should be removed from the rawhide repository.

 gnome-themes-extras     x86_64     0.8.0-3          extras-development  4.0 M
 gnome-themes-extras     noarch     0.8.1-1          extras-development  4.0 M

Comment 1 Matthias Saou 2005-07-22 13:55:15 UTC
This is also the case for i386 and ppc, as well as FC-4 (not just x86_64
development).

It shouldn't be a problem, though, unless the arch specific version is preferred
over the noarch one, even though it's older (but I doubt it). It is normal to
have old packages stick around for a while, but maybe there is a problem with
the removal of these because of the arch mismatch? Seth, could you please take
care of removing the old arch specific 0.8.0-3 packages if such is the case?

Comment 2 Seth Vidal 2005-07-22 14:16:05 UTC
can you find all of them and post them to the bug?

Comment 3 Matthias Saou 2005-08-02 09:17:50 UTC
4/i386/gnome-themes-extras-0.8.0-3.i386.rpm
4/ppc/gnome-themes-extras-0.8.0-3.ppc.rpm
4/SRPMS/gnome-themes-extras-0.8.0-3.src.rpm
4/x86_64/gnome-themes-extras-0.8.0-3.x86_64.rpm
development/i386/gnome-themes-extras-0.8.0-3.i386.rpm
development/ppc/gnome-themes-extras-0.8.0-3.ppc.rpm
development/SRPMS/gnome-themes-extras-0.8.0-3.src.rpm
development/x86_64/gnome-themes-extras-0.8.0-3.x86_64.rpm

The ones to keep being the noarch 0.8.1 packages.

Comment 4 Rudolf Kastl 2005-08-08 13:11:32 UTC
the problem is trivially that on a x86_64 install those packages are tried to be
installed in parallel when i reported that problem.

So on x86_64 rawhide this resulted in

yum install gnome-themes-extras 

-> both packages selected
-> install problem!

its not that i have anything against old versions sticking around in general ;)

Comment 5 Michael Schwendt 2005-08-08 19:15:45 UTC
Fixed in the master repository. May take a bit till changes propagate to mirrors.