Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161691

Summary: Editor switcher and view switcher does not work correctly
Product: [Fedora] Fedora Reporter: Steve Baker <steve>
Component: eclipseAssignee: Andrew Overholt <overholt>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: billy.biggs, eclipse-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 3.1.1-1jpp_1fc.FC4.4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-09 23:41:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 162443    
Bug Blocks:    

Description Steve Baker 2005-06-25 22:31:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Hitting ctrl-F6 should cycle through currently open files and ctrl-F7 should cycle through all active views. The list is ordered by most recently used.

The cycle popup displays but doesn't do anything. There is a flicker with each keypress so there might be some kind of focus problem. 

This is an important feature to me since I have too many files open for the editor tabs to be useful. 

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Start Eclipse
2. Open multiple files
3. hit ctrl-F6
3. hit ctrl-F6 again
3. stab ctrl-F6 rapidly with increasing frustration

Actual Results:  File switcher window displays but doesn't cycle though files. Switcher flickers with each ctrl-F6

Expected Results:  ctrl-F6 cycles through each file and selecting a file will make it active in the editor view. ctrl-shift-F6 will cycle in reverse order.

Additional info:

Window manager is metacity

Comment 1 Billy Biggs 2005-06-25 23:50:39 UTC
I am pretty sure this is this upstream bug which is fixed in 3.1RC1 and higher:

  https://bugs.eclipse.org/bugs/show_bug.cgi?id=95508

Comment 2 Steve Baker 2005-06-26 00:44:17 UTC
Sounds like this might be the issue. Any idea when this will be pushed to FC4?

Comment 3 Jeff Pound 2005-06-27 14:25:55 UTC
FC4 will have an eclipse update when 3.1 final is released.

Comment 4 Andrew Overholt 2005-11-02 15:23:37 UTC
We will have an Eclipse 3.1.1 update for FC4 hopefully today.