Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161665

Summary: After starting Eclipse Fedora 4 is hanging forever
Product: [Fedora] Fedora Reporter: Wolfgang Raith <wolfg.raith>
Component: eclipseAssignee: eclipse-bugs
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 4CC: andrea_caltroni
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-20 18:14:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Wolfgang Raith 2005-06-25 08:24:53 UTC
Description of problem:
At the end of the eclipse startup the ide is suddenly frozen and Fedora seems to
be hang. 

Version-Release number of selected component (if applicable):
Fedora 4 with all standard upgrades. Eclipse 3.1 

How reproducible:
Simply start Eclipse 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Wolfgang Raith 2005-06-25 08:29:21 UTC
By the way. I tested eclipse of the Fedora 4 distribution and eclipse 3.1 taken
from www.eclipse.org. Both results in a hanging system.
On the other hand I tested eclipse 3.1 also on SuSE 9.1 on the same computer.
There the problem did not happen. 

Comment 2 Andrew Overholt 2005-06-27 18:11:26 UTC
Were you running Eclipse as root?  If so, this is most likely a duplicate of:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152386

Comment 3 Andrew Overholt 2005-09-21 14:34:14 UTC
Any news here?

Comment 4 Andrea Caltroni 2005-10-19 09:39:50 UTC
I was using Eclipse v3.1 on Fedora core 1 and had no problem.
When I switched to Fedora core 4:

- Eclipse v3.1 is working but has some problems (selection highlighting does not
work)

- Eclipse v3.1.1 both the source recompiled with JDK 1.5 and the binary
distribution eclipse-SDK-3.1.1-linux-gtk.tar.gz do not work
1. in a new workspace:
-----
Unable to read workbench state.Workbench UI layout will be reset
-----
and then I have very few menu items enabled.

2. in a workspace with Eclipse projects, I do not have the previous error, but
when I try to open one project, I get:

Errors during build.
  Error instantiating builder: org.eclipse.jdt.core.javabuilder.
    Plug-in org.eclipse.jdt.core was unable to load class
org.eclipse.jdt.internal.core.builder.JavaBuilder.
  Plug-in org.eclipse.jdt.core was unable to load class
org.eclipse.jdt.internal.core.builder.JavaBuilder.

Comment 5 Andrea Caltroni 2005-10-19 09:49:00 UTC
I'm already back with an update:
If I try this with Eclipse 3.1.1:

<ECLIPSE_HOME>/eclipse -vm <JAVA_HOME>/jre/bin/java

and JDK v1.5.0_04, I do not have the problems of my previous post.

Comment 6 Andrew Overholt 2005-10-20 15:34:30 UTC
So we can close this bug, right?

Comment 7 Wolfgang Raith 2005-10-20 18:14:23 UTC
nsb-install-8-0.exe

YES, of course you can close the bug.

Thank you very much for your effort
Wolfgang Raith