Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161317

Summary: saslauthd memory leak
Product: [Retired] Fedora Legacy Reporter: Thomas Antony <thomas>
Component: cyrus-saslAssignee: Fedora Legacy Bugs <bugs>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: fc2CC: brunson, juvenal.jr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.irbs.net/internet/cyrus-sasl/0308/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-27 22:11:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Antony 2005-06-22 11:50:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.5) Gecko/20041108 Firefox/1.0

Description of problem:
I am running a mail server with postfix, cyrus-imapd, cyrus-sasl and mysql as backend.
Saslauthd uses with the time more and more memory until there is no swap space available and i run into huge troubles. Random daemons like ssh will exit because of not sufficient memory. I have to restart saslauthd on a regular basis to avoid this problem. 

Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.19-3

How reproducible:
Didn't try

Steps to Reproduce:
1. -

Actual Results:  saslauthd use all available memory

Additional info:

I have set "pwcheck_method: saslauthd" in smtpd.conf

There a several posting on the cyrus mailing lists which concerns this bug. I don't know if it has been already been fixed.

Comment 1 Thomas Antony 2005-06-22 12:02:55 UTC
I did a mistake with the release number which is cyrus-sasl-2.1.18-2.2 and not
cyrus-sasl-2.1.19-3!

Comment 2 Thomas Antony 2005-06-29 13:19:12 UTC
Adding FLAGS="-c -n 0" to /etc/sysconfig/saslauthd avoids the problem for me,
but the memory leak is still there.

Comment 3 Juvenal A. Silva Jr. 2005-07-20 22:33:23 UTC
I found the same problem with Red Hat Enterprise Linux ES 3 with package
cyrus-sasl-2.1.15-10.i386.rpm.
I'd like to really solve this problem, not only work-around it. Now I'm testing
the work-around to see if it's really effective.
I'm waiting your answer ASAP

Regards,

Juvenal A. Silva Jr.

Comment 4 Eric Brunson 2005-08-03 21:37:07 UTC
Postings to the Cyrus mailing list indicate that this is a memory leak in the
PAM modules that most of us are using via saslauthd.  Would anyone care to
comment on that?

Comment 5 Thomas Antony 2005-11-27 22:11:22 UTC
pam_mysql is causing the memory leaks.