Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 161089

Summary: Missing BuildRequires dependency on cvs
Product: Red Hat Enterprise Linux 4 Reporter: Andreas Thienemann <andreas>
Component: mcAssignee: Denys Vlasenko <dvlasenk>
Status: CLOSED CURRENTRELEASE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: leonard-rh-bugzilla, srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-15 15:16:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 185520    
Bug Blocks:    

Description Andreas Thienemann 2005-06-20 15:01:08 UTC
During a testbuild of mc-4.6.1-0.8.1 in mock, the rebuild process
stops with the following error:

+ CFLAGS='-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -O2 -g -pipe -m64'
+ ./autogen.sh --with-screen=slang --host=x86_64-redhat-linux-gnu
--build=x86_64-redhat-linux-gnu --target=x86_64-redhat-linux
-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
--sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr
/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec
--localstatedir=/var --sharedstatedir=/usr/com
--mandir=/usr/share/man --infodir=/usr/share/info --enable-charset
autopoint: *** cvs program not found
autopoint: *** Stop.
error: Bad exit status from /var/tmp/rpm-tmp.51781 (%build)

This problem seems to be present in rawhide as well.

Adding cvs to the BuildRequires: list should fix this issue.

Comment 1 Jindrich Novy 2005-06-22 13:32:04 UTC
The rawhide mc doesn't call autogen.sh at all therefore it doesn't call
autopoint and doesn't need the cvs dependency. I'll try to fix this by avoiding
the call of autogen and using configure instead.