Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160867

Summary: mc hangs when starting within zsh
Product: [Fedora] Fedora Reporter: Gérard Milmeister <gemi>
Component: mcAssignee: Jindrich Novy <jnovy>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: leonard-rh-bugzilla, pknirsch
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-21 12:02:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gérard Milmeister 2005-06-17 21:16:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
mc hangs when started within zsh, but not within bash.

Version-Release number of selected component (if applicable):
mc-4.6.1a-0.10.FC4

How reproducible:
Always

Steps to Reproduce:
1. Start mc within zsh
2. it is possible to select a directory
3. but when hitting enter to go into the directory, mc hangs
  

Additional info:

Comment 1 Jindrich Novy 2005-06-20 11:27:52 UTC
This works for me. Could you please go more into the detail how to reproduce it?

Comment 2 Gérard Milmeister 2005-06-20 18:30:26 UTC
I found out what the problem is:
I had set

bindkey "^j"      self-insert

I Removed this binding and mc works.
This binding  was set, so the CTRL-J would insert an new line in the midst of a
multi-line command-line.

Comment 3 Jindrich Novy 2005-06-21 12:02:03 UTC
Ok, thanks for finding the cause of the bug.