Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160785

Summary: netdump manpage not visible
Product: Red Hat Enterprise Linux 3 Reporter: David Grierson <david.grierson>
Component: netdumpAssignee: Dave Anderson <anderson>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3.0CC: buchholz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2006-0037 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-03-15 15:53:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 168424    
Attachments:
Description Flags
patch file which removes the copyright character causing man page problems. none

Description David Grierson 2005-06-17 09:31:11 UTC
Description of problem:

The manpage for netdump is not available due to some kind of problem with either
the iconv package or the netdump manpage file itself.

When attempting to view the manpage for netdump I receive the following error:

nbg01-shell-01{0}$ man netdump
iconv: illegal input sequence at position 124

When attempting to directly process the manpage file a similar error occurs:

nbg01-shell-01{0}$ gzip -dc /usr/share/man/man8/netdump.8.gz | nroff -man
iconv: illegal input sequence at position 31

The version of netdump is the latest distributed:

nbg01-shell-01{1}$ rpm -q netdump
netdump-0.7.7-2

The installed RPM files are all verified as per the RPM (except the
configuration file):

nbg01-shell-01{0}$ rpm -V netdump
S.5....T c /etc/sysconfig/netdump

Comment 1 Dave Anderson 2005-06-17 13:02:39 UTC
Works for me:

$ rpm -q netdump
netdump-0.7.7-2
$ rpm -V netdump
S.5....T c /etc/sysconfig/netdump
$ man netdump

NETDUMP-CLIENT(8)               System Programs              NETDUMP-CLIENT(8)

NAME
       netdump - send oops data and memory dumps over the network

SYNOPSIS
       /etc/init.d/netdump {start|stop|status|restart|propagate}

DESCRIPTION
       Loads and configures the netdump kernel modules. Once these are loaded,
       when the kernel crashes it will send the oops message  and  a  dump  of
       physical  memory  to the machine that runs the netdump-server. This can
       then be used to debug the problem using gdb and a kernel image.
...

$ gzip -dc /usr/share/man/man8/netdump.8.gz | nroff -man
NETDUMP-CLIENT(8)               System Programs              NETDUMP-CLIENT(8)



NAME
       netdump - send oops data and memory dumps over the network

SYNOPSIS
       /etc/init.d/netdump {start|stop|status|restart|propagate}

DESCRIPTION
       Loads and configures the netdump kernel modules. Once these are loaded,
       when the kernel crashes it will send the oops message  and  a  dump  of
       physical  memory  to the machine that runs the netdump-server. This can
       then be used to debug the problem using gdb and a kernel image.
...


However, maybe I've got an old version of iconv:

$ iconv --version
iconv (GNU libc) 2.3.2
Copyright (C) 2003 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Written by Ulrich Drepper.
$

What version are you running?

Comment 2 David Grierson 2005-06-17 13:13:54 UTC
Running 0.7.7-2

Appears to work for root but not for my user account but does for other users
... seems to be something in my environment - I will investigate further.

You can close this defect - do you want an update with outcome of environment
investigation?

Apologies for raising this too quickly.

Comment 3 Dave Anderson 2005-06-17 13:20:30 UTC
Not a problem -- looking back, I see another similar report on an earlier
version.

I'm presuming the problem would also happen with the netdump-server man
page as well, and maybe has something to do with the second line in each
page:


.\"             -*-Nroff-*-
.\" Copyright é 2002 Alexander Larsson <alexl@redhat.com>
.\"

That copyright character looks suspicious.  If you were to remove it, does
the problem go away?



Comment 4 David Grierson 2005-06-17 13:35:27 UTC
Created attachment 115611 [details]
patch file which removes the copyright character causing man page problems.

Comment 5 David Grierson 2005-06-17 13:37:51 UTC
Well spotted looks like that's what's causing it - perhaps a problem with nroff
rather than netdump?

nbg01-shell-01{1}$ diff netdump.8 netdump.8.orig
2c2
< .\" Copyright  2002 Alexander Larsson <alexl@redhat.com>
---
> .\" Copyright é 2002 Alexander Larsson <alexl@redhat.com>
Previous exit value was: 1
nbg01-shell-01{1}$ nroff -man netdump.8.orig
iconv: illegal input sequence at position 31
nbg01-shell-01{0}$ nroff -man netdump.8
NETDUMP-CLIENT(8)               System Programs              NETDUMP-CLIENT(8)



NAME
       netdump - send oops data and memory dumps over the network


Comment 6 Dave Anderson 2005-06-17 13:58:26 UTC
Ok fine -- I'll remove it for the next release...

Thanks,
  Dave


Comment 7 Dave Anderson 2005-06-17 14:12:15 UTC
*** Bug 124473 has been marked as a duplicate of this bug. ***

Comment 12 Red Hat Bugzilla 2006-03-15 15:53:57 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0037.html