Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160728 (irssi_and_perl)

Summary: irssi missing files
Product: [Fedora] Fedora Reporter: Idar Lund <idarlund>
Component: perlAssignee: Warren Togami <wtogami>
Status: CLOSED NOTABUG QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: perl-devel
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://idarlund.stud.hive.no/make_error_irssi_FC4
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-21 20:19:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Irssi compiling with gcc4 none

Description Idar Lund 2005-06-16 21:46:25 UTC
Description of problem:

I've a new fresh install of Fedora Core 4, with all packages installed from the
DVD iso.

I've installed irssi with yum who get it from the extra's reps. When trying to
load module script, i'm getting this error:

Irssi: Error loading module script/core:
/usr/lib/irssi/modules/libscript_core.so: cannot open shared object file: No
such file or directory

I figured out that i should try to compile it myselves to se what error messages
i got. Here is the result: http://idarlund.stud.hive.no/make_error_irssi_FC4

Version-Release number of selected component (if applicable): irssi 0.8.9-7 from
"extras"

Additional info: It may be an easy solution to this, eg. let us know what
package contains libscript_core.so :)

Comment 1 Idar Lund 2005-06-21 20:19:12 UTC
A friend of me was the first to discover this bug. And the first to fix it, hehe ;)

Here is what we did:
1) when we tryed to load script module we got an error that libscript_core.so
didn't exist
2) since he is a curious person he just tryed /load aaa, then he got this
strange message; libaaa_core.so was not found.
3) This seemed pretty strange so he desided to take a look in the
/usr/lib/irssi/modules/ folder to see what files it contained, we found
libfe_perl.so and libperl_core.so.
4) You've probably figured out by now what we did; /load perl :) as simply as
that. Irssi loaded:
22:06 -!- Irssi: Loaded module perl/core
22:06 -!- Irssi: Loaded module perl/fe
5) /script load my_1337_script.pl :)

Anyway.. we don't know yet why the compiling didn't work. And to the Fedora
team; why didn't FC4-extras-irssi load the perl module after the first install?
It did in the dag repo for FC3..

Hope this helps for all the other peoples that get the same errors as we got.

Btw. Sorry my bad english. Hope you all atleast understand it =)

Comment 2 Idar Lund 2005-06-23 04:24:41 UTC
Created attachment 115853 [details]
Irssi compiling with gcc4

To compile irssi with gcc4 for fc4, use this patch.

Comment 3 Idar Lund 2005-06-23 04:29:03 UTC
This will be the final comment i hope, as long as i/we don't find any other
problems about the same issues.
To compile irssi manually with gcc4 you'll need the patch i attached here. But
for all lacy people, you can get the *svn* rpg from
http://www.dubkat.info/download.php?project=rpms&file=irssi-0.8.10-rc5.svn.20050514_1801.sf.i386.rpm,
giving dubkat credits for this package ;)

More information about the gcc4-compiling-bug can be found at
http://bugs.irssi.org/?do=details&id=219, it's fixed in revision 3726
(svn.irssi.org)

Comment 4 Idar Lund 2005-06-23 20:24:14 UTC
Ups.. seems like the patch was corrupt while trasfered. You can get it here;
http://wouter.coekaerts.be/files/irssi-gcc4.diff