Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160440

Summary: no sound with Intel 82801FB/FBM/FR/FW/FRW, semaphore is not ready
Product: [Fedora] Fedora Reporter: Norman Gaywood <ngaywood>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-15 08:18:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
dmesg
none
lsmod
none
lspci -v
none
/etc/modprobe.conf none

Description Norman Gaywood 2005-06-15 06:58:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I have a Dell 610 laptop and I can't get the sound to work with system-config-soundcard.  On system boot, there is this in /var/log/messages:

kernel: codec_semaphore: semaphore is not ready [0x1][0x700300]
kernel: codec_write 0: semaphore is not ready for register 0x4
kernel: codec_semaphore: semaphore is not ready [0x1][0x700300]
kernel: codec_write 0: semaphore is not ready for register 0x4



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot Dell 610
2. Observe above syslog messages in /var/log/messages
3. Run system-config-soundcard and hear nothing on test sound
  

Actual Results:  system-config-soundcard seems to detect the sound card correctly but there is no sound when the test sound button is pressed.

Expected Results:  I sound hear something.

Additional info:

I tried muting the headphone which I saw helped some people in FC3 with sound problems. No help here.

This sound card worked with system-config-soundcard in FC3. This current system is a new install of FC4.

One thing that may make my setup different is that I have compiled the latest dri freedesktop code for the i915 display chip to get my display going. (I had to pretend that the FC4 kernel was 2.6.12 to make it compile). I also installed the dri code in FC3 and the sound was OK there.

Comment 1 Norman Gaywood 2005-06-15 07:04:08 UTC
Created attachment 115457 [details]
dmesg

Comment 2 Norman Gaywood 2005-06-15 07:04:45 UTC
Created attachment 115458 [details]
lsmod

Comment 3 Norman Gaywood 2005-06-15 07:05:28 UTC
Created attachment 115460 [details]
lspci -v

Comment 4 Norman Gaywood 2005-06-15 07:06:28 UTC
Created attachment 115461 [details]
/etc/modprobe.conf

Comment 5 Norman Gaywood 2005-06-15 08:18:04 UTC
Seems I have to enable "external amp" in gnome-mixer. Sound now works.

https://www.redhat.com/archives/fedora-list/2005-June/msg02142.html

Closed, not a bug.