Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160404

Summary: Installer doesn't detect SATA HD with SIS 965L chipset.
Product: [Fedora] Fedora Reporter: Antoni Reus <areus>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED CANTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: davej, peterm, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-11-19 09:03:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 169613    

Description Antoni Reus 2005-06-14 21:48:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The chipset SiS 965L is not supported by the sata_sis module included in FC4, so SATA HD are not detected during the istal┬Ělation.

SiS already has provided drivers for this chipset (www.sis.com).

A workarround to install FC4 on boxes with this chipset is to 
 1- add and IDE hardrive to the box 
 2- install FC4 in the IDE hardrive
 3- Download the src form the Fedora kernel and try to merge the SiS provided driver. 
 4- rebuild the modules, rebuild initrd, 
 5- Reboot, SATA should be detected now.
 6- Copy the contents of the IDE hardrive to the SATA hardrive, update /etc/fstab, grub.conf ...
 7- Reboot

and repeat 3 and 4 for every kernel upgrade.

 - 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot instalation DVD/CD
2.Follow steps until hd partitioning
3.
  

Actual Results:  No hd detected

Expected Results:  Hd detected

Additional info:

Comment 1 Dave Jones 2005-07-15 21:40:23 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 2 Antoni Reus 2005-07-18 07:01:43 UTC
Chipset Sis 965L still not supported by module sata_sis

Comment 3 Dave Jones 2005-11-10 20:16:12 UTC
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.


Comment 4 Dave Jones 2005-11-19 09:03:32 UTC
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.