Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160350

Summary: Kernel panic when trying to install
Product: [Fedora] Fedora Reporter: Starchild <kristerkjellstrom>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 4CC: anders.blomdell, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-14 17:06:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Starchild 2005-06-14 16:11:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5

Description of problem:
Basically, I boot up from the dvd and get the boot>
If I press enter to enter the graphical setup, I immediatly get a Kernel Panic.

If I try to do a media check, using "linux mediacheck", I immediatly get a Kernel Panic.

I haven't tried to start the installer in text-mode, but I really don't expect it to work.

Tried using acpi=ht, still the same result. (I'm using a P4)

Version-Release number of selected component (if applicable):
FC4-dvd

How reproducible:
Always

Steps to Reproduce:
1.boot up from dvd
2.press enter at the boot> promt
  

Actual Results:  This is what I see:
[<c01002b8>] init+0x18/0xf0
[<c01012b1>] kernel_thread_helper+0x5/0x14
Code: c8 fc ff 8b 45 4c 3d 3c 4b 24 1d 74 90 e8 8e ca fc ff 8d 55 4c 50 52 68 6a 01 00 00 68 88 c0 37 c0 68 28 4b 37 c0 e8 c5 c8 fc ff <0f> 0b 1e 01 88 c0 37 c0 e9 7b fe ff ff 8b 54 24 3c 8b 44 24 08
<0>Kernel Panic - not syncing: attempted to kill init!
[<c01201eb>] panic+0x3b/0x1b0
[<c0124162>] do_exit+0x482/0x4d0
[<c0104601>] die+0x201/0x270
[<c01048a0>] do_invalid_op+0x0/0xa0
[<c0104931>] do_invalid_op+0x91/0xa0
[<c01538eb>] free_pages_bulk+2db/0x350
[<c025c7d2>] set_cursor+0x52/0x70
[<c025f312>] vt_console_print+0x162/0x290
[<c025f160>] vt_console_print+0x0/0x290
[<c0120c37>] __call_console_drivers+0x37/0x50
[<c0123d37>] call_console_drivers+0x87/0x150
[<c0103caf>] error_code+0x4f/0x60 
[<c01538eb>] free_pages_bulk+2db/0x350
[<c015406b>] free_hot_cold_page+0x7b/0xd0
[<c0118306>] free_initrd_mem+0x56/0x70
[<c01002a0>] init+0x0/0xf0
[<c01002b8>] init+0x18/0xf0
[<c01013b1>] kernel_thread_helper+0x5/0x14

It just stops there.
If there was anything before that, I couldn't see it, and shift+pgup didn't work.

Expected Results:  To enter the graphical install enviroment.

Additional info:

the system is an HP pavilion 1080.se
Motherboard is listed as "MS-6577", though I think it's a remaned asus.

I'm currently running FC 2

Comment 1 Starchild 2005-06-14 16:16:17 UTC
Ah, right, forgot to mention, The media is sound. sha1 checks out, as does the
md5-sums for allt the images on the disc. checked all files in /images
/images/pxeboot and /isolinux

Comment 2 Anders Blomdell 2005-06-14 17:04:22 UTC
Same problem here,  but only on machines with Intel 915 chipset (and SATA disks if that is of 
relevance). The first error message I was able to see complained about "Unable to mount root disk"

Comment 3 Bill Nottingham 2005-06-14 17:06:12 UTC

*** This bug has been marked as a duplicate of 159026 ***