Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1601307

Summary: Logging installation failed at TASK [openshift_logging_fluentd : Label OCP nodes for Fluentd]
Product: OpenShift Container Platform Reporter: Junqi Zhao <juzhao>
Component: LoggingAssignee: Jeff Cantrill <jcantril>
Status: CLOSED ERRATA QA Contact: Anping Li <anli>
Severity: high Docs Contact:
Priority: medium    
Version: 3.7.1CC: aos-bugs, juzhao, rmeggins
Target Milestone: ---Keywords: Regression
Target Release: 3.7.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: Undefined variable in the fluentd role Consequence: The deployment failed trying to label the nodes Fix: Replaced variable with the correct one to the oc client binary Result: Logging deployment is possible and properly labels the nodes.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-08-09 22:14:04 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Junqi Zhao 2018-07-16 03:08:18 UTC
Description of problem:
Deploy logging 3.7, ansible threw out error

fatal: [###############]: FAILED! => {"failed": true, "msg": "the field 'args' has an invalid value, which appears to include a variable that is undefined. The error was: 'openshift_client_binary' is undefined\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_logging_fluentd/tasks/main.yaml': line 208, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n# We need to pause between nodes while labeling to avoid overloading the scheduler.\n- name: Label OCP nodes for Fluentd\n  ^ here\n"}

Version-Release number of selected component (if applicable):
openshift-ansible-3.7.58-1.git.37.6db1e6f.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging 3.7
2.
3.

Actual results:
Logging installation failed at TASK [openshift_logging_fluentd : Label OCP nodes for Fluentd]

Expected results:
Installation is successfully

Additional info:
openshift_logging_install_logging=true
openshift_logging_image_prefix=${IMAGE_PREFIX}
openshift_logging_image_version=v3.7

Comment 1 Jeff Cantrill 2018-07-16 17:05:40 UTC
Please identify the version of ansible being used.

Comment 2 Junqi Zhao 2018-07-17 00:24:36 UTC
(In reply to Jeff Cantrill from comment #1)
> Please identify the version of ansible being used.

ansible-2.3.2.0-2.el7.noarch

Comment 4 Junqi Zhao 2018-07-18 00:21:34 UTC
Need new openshift-ansible package to verify this defect, the currently latest version is 3.7.59-1 which does not include the fix

Comment 6 Junqi Zhao 2018-07-31 01:54:23 UTC
Tested, logging could be installed successfully without error

# rpm -qa | grep ansible
openshift-ansible-lookup-plugins-3.7.61-1.git.0.36791ef.el7.noarch
openshift-ansible-3.7.61-1.git.0.36791ef.el7.noarch
openshift-ansible-filter-plugins-3.7.61-1.git.0.36791ef.el7.noarch
openshift-ansible-playbooks-3.7.61-1.git.0.36791ef.el7.noarch
openshift-ansible-callback-plugins-3.7.61-1.git.0.36791ef.el7.noarch
openshift-ansible-docs-3.7.61-1.git.0.36791ef.el7.noarch
ansible-2.3.2.0-2.el7.noarch
openshift-ansible-roles-3.7.61-1.git.0.36791ef.el7.noarch

Comment 8 errata-xmlrpc 2018-08-09 22:14:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2337