Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1600716

Summary: SELinux is preventing upowerd from 'remove_name' accesses on the directory history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ.
Product: [Fedora] Fedora Reporter: Mikhail <mikhail.v.gavrilov>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dwalsh, lvrabec, mgrepl, plautrba, pmoore
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:53d7769ee0585faf50b6c2b6128d7f48dda0e8854aba1a32edc5a34f764cde29;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-22 11:38:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mikhail 2018-07-12 20:29:56 UTC
Description of problem:
SELinux is preventing upowerd from 'remove_name' accesses on the directory history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that upowerd should be allowed remove_name access on the history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'upowerd' --raw | audit2allow -M my-upowerd
# semodule -X 300 -i my-upowerd.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:devicekit_var_lib_t:s0
Target Objects                history-rate-Sony_Interactive_Entertainment_Wirele
                              ss_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ [ dir ]
Source                        upowerd
Source Path                   upowerd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.2-26.fc29.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.18.0-0.rc0.git9.1.fc29.x86_64 #1
                              SMP Thu Jun 14 18:07:49 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-07-11 08:41:20 +05
Last Seen                     2018-07-11 08:41:20 +05
Local ID                      0b8a0595-5b2a-4a78-b77b-8d55d4fab101

Raw Audit Messages
type=AVC msg=audit(1531280480.730:501): avc:  denied  { remove_name } for  pid=1278 comm="upowerd" name="history-rate-Sony_Interactive_Entertainment_Wireless_Controller-f4:93:9f:56:03:cb.dat.I1KBMZ" dev="sdc1" ino=6160472 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:devicekit_var_lib_t:s0 tclass=dir permissive=1


Hash: upowerd,init_t,devicekit_var_lib_t,dir,remove_name

Version-Release number of selected component:
selinux-policy-3.14.2-26.fc29.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.18.0-0.rc4.git3.1.local.fc29.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-07-22 11:38:51 UTC

*** This bug has been marked as a duplicate of bug 1600718 ***