Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1600149

Summary: CA Agent UI -> List Requests -> Starting request number: search field does not work as expected
Product: Red Hat Enterprise Linux 7 Reporter: Roshni <rpattath>
Component: pki-coreAssignee: RHCS Maintainers <rhcs-maint>
Status: NEW --- QA Contact: Asha Akkiangady <aakkiang>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7.6CC: mharmsen
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
CA debug log during this issue none

Description Roshni 2018-07-11 14:16:17 UTC
Created attachment 1458123 [details]
CA debug log during this issue

Description of problem:
CA Agent UI -> List Requests -> Starting request number: search field does not work as expected

Version-Release number of selected component (if applicable):
pki-ca-10.5.9-1.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Access CA agent Web UI
2. Click List Requests
3. If you have a certificate request with request ID less than (decimal) 50, then enter 50 in the Starting request number box. 

Actual results:
Certificate request with request ID 27 is listed

Expected results:


Additional info:
I have a pending request with request ID 27. I tried various values in this field, attaching log messages when these values were tried.