Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 160004

Summary: up2date ignores pkgskiplist
Product: Red Hat Enterprise Linux 4 Reporter: Thomas Cameron <thomas.cameron>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED NOTABUG QA Contact: Fanny Augustin <fmoquete>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-20 05:35:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Cameron 2005-06-09 23:14:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
I have installed my own RPMs for SpamAssassin.  I added spamassassin* and perl-Mail-SpamAssassin* to the pkgSkipList section of /etc/sysconfig/rhn/up2date by using up2date --configure --nox.  I verify that the entry is there:

[root@wintermute up2date]# grep -i pkgskip /etc/sysconfig/rhn/up2date|grep -v comment
pkgSkipList=spamassassin*;perl-Mail-SpamAssassin*;

When I run up2date -u, I get this error:

There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
spamassassin-tools-3.0.4-1 requires perl-Mail-SpamAssassin = 3.0.4-1 

I want up2date to leave these packages alone.

Version-Release number of selected component (if applicable):
up2date-4.4.5.6-2

How reproducible:
Always

Steps to Reproduce:
1. install a newer version of an RPM than is in RHN
2. exclude that RPM via up2date --configure
3. run up2date -u
4. cuss when it is not skipped
  

Actual Results:  I get an "Unresolvable chain of dependencies:" error message

Expected Results:  It should skip the packages.

Additional info:

Comment 1 Rahul Sundaram 2005-06-14 10:24:59 UTC
This is not reproducible in my system. Tried with several different packages in
spamassasin and xorg-x11* ones. The ignore list works as expected

Comment 2 Thomas Cameron 2005-06-14 14:10:13 UTC
This is weird - I have reproduced it on two systems here.  One with
SpamAssassin, and one with XMMS.  

*** Please note that these RPMS built from the vendor's web site, *not* the ones
that come with RHEL or up2date. ***

For example, grab http://www.xmms.org/files/1.2.x/rpm/xmms-1.2.10-1.src.rpm, do
rpmbuild --rebuild on it, and remove the Red Hat supplied xmms* packages (this
will require that you uninstall kdenetwork-nowlistening and kdeaddons-xmms if
you have KDE installed).

Now install all of the xmms* packages you get from rebuilding the xmms.org
source RPM.  Add xmms* to your pkgSkipList entry, and then run up2date.

Here's what happens on my system:

[root@ml110 ~]# rpm -q kdeaddons-xmms xmms xmms-devel xmms-flac xmms-skins
kdenetwork-nowlistening
kdeaddons-xmms-3.3.1-2
xmms-1.2.10-9
xmms-devel-1.2.10-9
xmms-flac-1.1.0-7
xmms-skins-1.2.10-9
kdenetwork-nowlistening-3.3.1-2

[root@ml110 ~]# rpm -e kdeaddons-xmms xmms xmms-devel xmms-flac xmms-skins
kdenetwork-nowlistening

[root@ml110 ~]# cd /home/thomas.cameron/redhat/RPMS/i386/
[root@ml110 i386]# rpm -Uvh xmms-*
Preparing...                ########################################### [100%]
   1:xmms                   ########################################### [ 14%]
   2:xmms-alsa              ########################################### [ 29%]
   3:xmms-devel             ########################################### [ 43%]
   4:xmms-esd               ########################################### [ 57%]
   5:xmms-gl                ########################################### [ 71%]
   6:xmms-mikmod            ########################################### [ 86%]
   7:xmms-vorbis            ########################################### [100%]

[root@ml110 i386]# grep -i pkgskip /etc/sysconfig/rhn/up2date | grep -v comment
pkgSkipList=xmms*;

[root@ml110 i386]# up2date -u

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-extras...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...
Name                                    Version        Rel     
----------------------------------------------------------
xmms                                    1.2.10         9          
xmms-devel                              1.2.10         9          


Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
file /usr/lib/xmms/Output/libALSA.so from install of xmms-1.2.10-9
h file from package xmms-alsa-1.2.10-1
file /usr/lib/xmms/Input/libvorbis.so from install of xmms-1.2.10-
th file from package xmms-vorbis-1.2.10-1

So you see, even though I have excluded xmms* in my up2date config file, it
still tries to install it via up2date.

I can also give you screen scrapes of the same issue with SpamAssassin RPMs
created from the spamassassin.apache.org web site.

Help?

Comment 3 Thomas Cameron 2005-06-18 13:46:49 UTC
OK, please close this ticket.  This is user error, I apologize.  I had set
forceInstall=1 to address an unrelated issue and forgot about it.  Sorry for
wasting the time.

Comment 4 Rahul Sundaram 2005-06-18 20:28:52 UTC
Ok. Good to know. Was getting puzzled over this.  Thank you for the update.
Kindly Close