Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159886

Summary: update to kernel-2.6.9-11.EL requires ipw2200-firmware > 2.0-3 which is not available in my channel
Product: Red Hat Enterprise Linux 4 Reporter: Robert Williams <bob>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: notting, pfrields, ubeck
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-09 16:16:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Robert Williams 2005-06-08 20:50:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.4.1

Description of problem:
I cannot update to kernel-2.6.9-11.EL because an
unsatisfied dependency for ipw2200-firmware >= 2.2.
Only 2.0-3 is available from my ES4 channel.
I see this:

There was a package dependency problem.  The message was:

Unresolvable chain of dependencies:
kernel-2.6.9-11.EL                       conflicts with ipw2200-firmware < 2.2 


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

Please modify your package selections and try again.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run Up2date and select all packages, including the kernel.
2.
3.
  

Actual Results:  See above.   Udates are blocked.

Expected Results:  up2date should find a recent ipw2200-firmware and update
that to satisfy the dependency for kernel-2.6.9-11.EL.

Additional info:

The workaround is to not update the kernel.

Comment 1 Uwe Beck 2005-06-08 23:41:18 UTC
Only ipw2200-firmware-2.0-3 available in extra channel, but kernel-2.6.9-11.EL
conflicts with ipw2200-firmware < 2.2
At this time you must remove ipw2200-firmware-2.0-3 if you want install the new
kernel. This is not a good idee if you need ipw2200-firmware on the system.


Comment 2 Bill Nottingham 2005-06-09 03:46:09 UTC
New ipw2200-firmware should be pushed to the new channel soon - hopefully by
tomorrow at the latest.

Comment 3 Robert Williams 2005-06-09 17:49:28 UTC
ipw2200-firmware-2.2-1.noarch is now on the ES v4 Extras channel,
but up2date doesn't recognize that it is available to update
the earlier version that I have installed.  I'm updating this one
by hand right now.