Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159841

Summary: Field names are misleading in configuration and '_' disallowed
Product: [Retired] Red Hat Cluster Suite Reporter: Rob Kenna <rkenna>
Component: redhat-config-clusterAssignee: Jim Parsons <jparsons>
Status: CLOSED NOTABUG QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-09-07 19:29:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rob Kenna 2005-06-08 16:01:51 UTC
The fields of fence device input panel are very misleading. The "Hostname"
should have been IP Address and the "Name" should have been something more
obviously labelled (maybe "Label" or even "Hostname" ?).

2.2 "Name" rule is not well known. One thing we noticed is that it doesn't take
"_" (say "star_war" got bounced back).

Comment 1 Jim Parsons 2005-06-08 16:18:50 UTC
The field names are not misleading in my opinion - they match the attribute
values  in the xml file that they are setting. That is where the names came
from. Please don't think they were assigned in an arbitrary manner.

That said, the field names are text strings in the glade file. they are easy to
amend. I will set them to any value that is decided upon -- note, however, that
if you change 'Hostname' to 'IP Address', the attribute in the xml file will
still need to be 'hostname="value"', which may cause a disconnect in the minds
of those who use emacs to touch up their configuration file.

Comment 2 Corey Marthaler 2005-09-07 19:29:08 UTC
The underscore issue was fixed and documented in another bz a long time ago, and
since there wasn't any feed back to Jim's comment, I'm closing this.