Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1598103

Summary: make slapd more descriptive if certs are missing in nssdb
Product: [Fedora] Fedora Reporter: Matus Honek <mhonek>
Component: openldapAssignee: Matus Honek <mhonek>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 28CC: mhonek, pkis, rmeggins
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openldap-2.4.46-2.fc28 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1543955 Environment:
Last Closed: 2018-07-11 20:20:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1543955    
Bug Blocks:    

Description Matus Honek 2018-07-04 10:59:53 UTC
Please note some parts were redacted from the description below.

+++ This bug was initially created as a clone of Bug #1543955 +++

Description of problem:
if extyected certificate is missing in the nssdb, slapd logs 'Could not get the realpath: No such file or directory' which is not really descriptive as it should not be a file and there's also no information it is connected to certificates.

How reproducible:
100%

Steps to Reproduce:
1. configure slapd to use nssdb
2. put only ca to nssdb
3. run the service

Actual results:
  Status of the failed service:
    Redirecting to /bin/systemctl status slapd.service
    ● slapd.service - OpenLDAP Server Daemon
    Loaded: loaded (/usr/lib/systemd/system/slapd.service; disabled; vendor preset: disabled)
    Drop-In: /etc/systemd/system/slapd.service.d
    └─slapd.conf
    Active: failed (Result: exit-code) since Pá 2018-02-09 16:33:02 CET; 180ms ago
    Docs: man:slapd
    man:slapd-config
    man:slapd-hdb
    man:slapd-mdb
    file:///usr/share/doc/openldap-servers/guide.html
    Process: 11444 ExecStart=/usr/sbin/slapd -u ldap -h ${SLAPD_URLS} $SLAPD_OPTIONS (code=exited, status=1/FAILURE)
    Process: 11431 ExecStartPre=/usr/libexec/openldap/check-config.sh (code=exited, status=0/SUCCESS)
    
    úno 09 16:33:01 <hostname> systemd[1]: Starting OpenLDAP Server Daemon...
    úno 09 16:33:01 <hostname> runuser[11434]: pam_unix(runuser:session): session opened for user ldap by (uid=0)
    úno 09 16:33:02 <hostname> slapd[11444]: @(#) $OpenLDAP: slapd 2.4.44 (Jan 31 2018 17:04:46) $
    mockbuild@<buildhost>:/builddir/build/BUILD/openldap-2.4.44/openldap-2.4.44/servers/slapd
    úno 09 16:33:02 <hostname> slapd[11444]: Could not get the realpath: No such file or directory
    úno 09 16:33:02 <hostname> systemd[1]: slapd.service: control process exited, code=exited status=1
    úno 09 16:33:02 <hostname> systemd[1]: Failed to start OpenLDAP Server Daemon.
    úno 09 16:33:02 <hostname> systemd[1]: Unit slapd.service entered failed state.
    úno 09 16:33:02 <hostname> systemd[1]: slapd.service failed.


Expected results:
mention that the missing thing is certificate,
it might be good to also distinguish between physical file and certificate from nssdb

Comment 2 Fedora Update System 2018-07-04 12:00:16 UTC
openldap-2.4.46-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-13bcf869cf

Comment 3 Fedora Update System 2018-07-04 18:22:44 UTC
openldap-2.4.46-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-13bcf869cf

Comment 4 Fedora Update System 2018-07-11 20:20:50 UTC
openldap-2.4.46-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.