Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1596438

Summary: Missing `fedpkg request-branch`
Product: [Fedora] Fedora Documentation Reporter: Alois Mahdal <amahdal>
Component: packager-guideAssignee: Petr Kovar <pkovar>
Status: CLOSED NOTABUG QA Contact: Fedora Docs QA <docs-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: develCC: pkovar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-10 16:04:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alois Mahdal 2018-06-29 00:55:46 UTC
Description of problem
======================

In Join_the_package_collection_maintainers, the step "Import, commit, and build your package" is directly followed by "Update Your Branches (if desired)", and "Submit Package as Update in Bodhi".

    https://fedoraproject.org/wiki/Join_the_package_collection_maintainers?rd=PackageMaintainers/Join#Import.2C_commit.2C_and_build_your_package

However the step "update branches" cannot succeed, since branches are not created automatically.  Sure, this step is optional, but even opting out, the next step about Bodhi won't be valid, because pushing master to Bodhi is not allowed.

Easiest fix would be to add command such as `fedpkg request-branch f28`, as I've been advised on mailing list and IRC:

    https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/I6A2VMIUPT2VVS3VAENF5MYOUYYXLE54/

One more note: to new packager, it's not clear if they should "desire" to update/push to new branches; because new packager might not expect this (adding new package to already released branch) to be allowed by policy.  It would be nice to give a hint to the packager on this.

Comment 1 Petr Kovar 2019-02-10 16:04:38 UTC
This BZ component is intended for the retired Fedora Packager Guide. Wiki issues should be fixed in the wiki directly.