Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1596152

Summary: [downstream clone - 4.2.6] enable migration for cpu pinned VMs
Product: Red Hat Enterprise Virtualization Manager Reporter: RHV Bugzilla Automation and Verification Bot <rhv-bugzilla-bot>
Component: rhvm-setup-pluginsAssignee: Sharon Gratch <sgratch>
Status: CLOSED ERRATA QA Contact: Liran Rotenberg <lrotenbe>
Severity: high Docs Contact:
Priority: high    
Version: 4.2.6CC: dfediuck, gklein, lsurette, mavital, michal.skrivanek, ratamir, sgratch, steve.goodman
Target Milestone: ovirt-4.2.6Keywords: Rebase, ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Enhancements Only
Doc Text:
This update removes the configuration parameter "CpuPinMigrationEnabled" from the vdc_options table in the database. With this update, live migration of High Performance virtual machines renders this configuration parameter unnecessary. (BZ#1457250)
Story Points: ---
Clone Of: 1596151
: 1613471 (view as bug list) Environment:
Last Closed: 2018-09-04 13:44:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1596151    
Bug Blocks: 1611968, 1613471    

Description RHV Bugzilla Automation and Verification Bot 2018-06-28 10:36:58 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1596151 +++
======================================================================

ḹet's enable migration for pinned VMs, required HP VMs migration - bug 1571024

(Originally by michal.skrivanek)

Comment 1 RHV Bugzilla Automation and Verification Bot 2018-06-28 10:37:01 UTC
the option is not effective anyway as there are other frontend validations

(Originally by michal.skrivanek)

Comment 4 Sharon Gratch 2018-07-23 12:54:45 UTC
The patch was not back-ported for 4.2.5, so changing back to ASSIGNED.

Comment 5 Sharon Gratch 2018-07-23 13:04:51 UTC
patch: https://code.engineering.redhat.com/gerrit/#/c/144708/

Comment 6 Sharon Gratch 2018-07-26 12:42:32 UTC
new patch link: https://code.engineering.redhat.com/gerrit/#/c/145190/

Comment 9 Liran Rotenberg 2018-08-08 13:05:29 UTC
Tried to verify on:
ovirt-engine-4.2.6-0.1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.2.6-0.1.el7ev.noarch
ovirt-engine-setup-4.2.6-0.1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.2.6-0.1.el7ev.noarch
rhvm-setup-plugins-4.2.11-1.el7ev.noarch
ovirt-engine-setup-base-4.2.6-0.1.el7ev.noarch

Steps:
1. Tried to CPU pin a VM in the web admin UI.
2. Tried to pin a VM to host(with allow manual migration).
3. Pin a VM to host(without migration).
3a. Tried to set the host with the VM running into maintenance.
4. Connect to the engine via SSH
4a. Run:
# su - postgres
# psql -d engine
engine=# select * from vdc_options where option_name = 'CpuPinMigrationEnabled';

Results:
As said in comment #1 (for steps 1-3):
In steps 1-2 I couldn't pin the CPU of the VM in the UI.
In step 3, the host couldn't enter into maintenance mode due to the VM.
In step 4:
 option_id |      option_name       | option_value | version 
-----------+------------------------+--------------+---------
         2 | CpuPinMigrationEnabled | false        | general
(1 row)

Comment 11 Michal Skrivanek 2018-08-09 04:27:42 UTC
(In reply to Sharon Gratch from comment #10)
> Hi Michal,
> 
> The only relevant result in QE's verification for this fix is step 4:
> The value of "CpuPinMigrationEnabled" is still set to false.
> 
> I checked content of [1] and see that the patch [2] was merged as required,
> i.e. the overridden of CpuPinMigrationEnabled to false in config.py file was
> removed.

 These are internal links to internal builds, do not belong to a public comment

> Any idea why installing rhv 4.2.6 doesn't override the value of
> CpuPinMigrationEnabled parameter to true as done in upstream? 
> Maybe we should explicitly set it to true instead of removing the overridden?

Well, do you see any override incase it’s already false? We’ll need to fix it differently for existing setups...
I’d actually suggest to just remove that option from ovirt-engine altogether. It’s useless on its own anyway

Comment 14 Liran Rotenberg 2018-08-29 10:13:21 UTC
Verified on:
ovirt-engine-4.2.6.4-0.1.el7ev.noarch
rhvm-setup-plugins-4.2.11-1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-4.2.6.4-0.1.el7ev.noarch
ovirt-engine-setup-4.2.6.4-0.1.el7ev.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-4.2.6.4-0.1.el7ev.noarch
ovirt-engine-setup-base-4.2.6.4-0.1.el7ev.noarch

Steps:
1. Connect to the engine via SSH
2. Run:
# su - postgres
# psql -d engine
engine=# select * from vdc_options where option_name = 'CpuPinMigrationEnabled';

Results:
 option_id | option_name | option_value | version 
-----------+-------------+--------------+---------
(0 rows)

Comment 15 Sharon Gratch 2018-09-02 12:53:20 UTC
Steve,

This old doc text is obsolete and should be changed to something like:
Remove the config parameter called "CpuPinMigrationEnabled" (appears on DB in vdc_options table) in downstream and upstream installations. 
This change was done to support High Performance VM live migration (BZ 1457250)

The same text as for upstream bz - https://bugzilla.redhat.com/show_bug.cgi?id=1596151

Comment 16 Steve Goodman 2018-09-02 14:13:39 UTC
Sharon, what I understand from your note is:

* High Performance Virtual Machine live migration is enabled by default (i.e. if you don't specify CpuPinMigrationEnabled is "false", it is "true" by default). 
* If you want to disable this parameter then you specify it as "false"?

Does the same thing apply to this bug: https://bugzilla.redhat.com/show_bug.cgi?id=1611968

Comment 17 Steve Goodman 2018-09-03 10:55:34 UTC
From Sharon's doc text: The same text as for upstream bz - https://bugzilla.redhat.com/show_bug.cgi?id=1596151

Does this mean that I should edit the doc text in 1596151?

Comment 18 Sharon Gratch 2018-09-03 11:46:03 UTC
(In reply to Steve Goodman from comment #16)
> Sharon, what I understand from your note is:
> 
> * High Performance Virtual Machine live migration is enabled by default
> (i.e. if you don't specify CpuPinMigrationEnabled is "false", it is "true"
> by default). 
> * If you want to disable this parameter then you specify it as "false"?
> 
> Does the same thing apply to this bug:
> https://bugzilla.redhat.com/show_bug.cgi?id=1611968

Not exactly, this bug was just for removing the CpuPinMigrationEnabled config parameter from the downstream installation scripts. The same removal was done for upstream installation as well (BZ 1596151) but since there was a special reference to this parameter from the downstream installation, we also needed this fix.
This removal was done as a pre-requisite for High Performance vms migration feature.

Comment 19 Sharon Gratch 2018-09-03 11:50:33 UTC
(In reply to Steve Goodman from comment #17)
> From Sharon's doc text: The same text as for upstream bz -
> https://bugzilla.redhat.com/show_bug.cgi?id=1596151
> 
> Does this mean that I should edit the doc text in 1596151?

I think you should verify the phrasing for doc text of BZ 1596151 but the content there is ok. It handles the CpuPinMigrationEnabled config parameter removal from upstream.

Comment 21 errata-xmlrpc 2018-09-04 13:44:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2627