Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1596062

Summary: Fedora-Cloud-Base - qcow2 - eth0 is not UP
Product: [Fedora] Fedora Reporter: Bruno Goncalves <bgoncalv>
Component: distributionAssignee: Josh Boyer <jwboyer>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dan, dkaspar, dustymabe, john.j5live, jonathan, kdudka, kevin, lnykryn, normand, zbyszek
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-07-20 13:08:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bruno Goncalves 2018-06-28 08:01:22 UTC
Description of problem:
After updating initscripts to initscripts-9.83-1.fc29.x86_64 the qcow2 image does not bring eth0 up.

Version-Release number of selected component (if applicable):
initscripts-9.83-1.fc29.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Download qcow2 image:
https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180615.n.0/compose/Cloud/x86_64/images/Fedora-Cloud-Base-Rawhide-20180615.n.0.x86_64.qcow2
2. bring it up and update initscripts there.
dnf install --disablerepo=* https://kojipkgs.fedoraproject.org//packages/initscripts/9.83/1.fc29/x86_64/initscripts-9.83-1.fc29.x86_64.rpm
3. reboot
4. during boot you can see eth0 is not UP:

         Starting Initial cloud-init job (metadata service crawler)...
[   82.819590] cloud-init[493]: Cloud-init v. 17.1 running 'init' at Thu, 28 Jun 2018 07:50:19 +0000. Up 81.83 seconds.
[   82.830228] cloud-init[493]: ci-info: +++++++++++++++++++++++++++Net device info++++++++++++++++++++++++++++
[   82.840308] cloud-init[493]: ci-info: +--------+-------+-----------+-----------+-------+-------------------+
[   82.850239] cloud-init[493]: ci-info: | Device |   Up  |  Address  |    Mask   | Scope |     Hw-Address    |
[   82.859962] cloud-init[493]: ci-info: +--------+-------+-----------+-----------+-------+-------------------+
[   82.869918] cloud-init[493]: ci-info: | eth0:  | False |     .     |     .     |   .   | 52:54:00:12:34:56 |
[   82.879968] cloud-init[493]: ci-info: |  lo:   |  True | 127.0.0.1 | 255.0.0.0 |   .   |         .         |
[   82.890433] cloud-init[493]: ci-info: |  lo:   |  True |     .     |     .     |   d   |         .         |
[  OK  ] Started Initial cloud-init job (metadata service crawler).
[   82.900678] cloud-init[493]: ci-info: +--------+-------+-----------+-----------+-------+-------------------+



Actual results:
 eth0:  | False |

Expected results:
| eth0:  | True | 10.0.2.15 | 255.255.255.0 |   .   | 52:54:00:12:34:56 |

Additional info:
it works well with initscripts-9.82-1.fc29.x86_64

Comment 1 Lukáš Nykrýn 2018-06-28 10:19:41 UTC
The network-scripts were split from the initscripts package. In your case, you just specified that you want to only upgrade the main package, so ended up without network-scripts, but the general "dnf upgrade" path works. So I don't think that this is a problem:

https://paste.fedoraproject.org/paste/DtR7Xnr9VQtrhhHtIseK3Q

But, the fact that cloud images still use network-scripts is the actual bug here. There was a fesco decision, that they should be moved to networkd years ago.

These days I would be more for NetworkManager, but definitely not the old scripts. This needs to be investigated and fixed.

Comment 2 Dusty Mabe 2018-06-28 12:49:13 UTC
I'm thinking we should just add in NetworkManager in the cloud base image since that's what the rest of Fedora uses.

Comment 3 Bruno Goncalves 2018-06-28 13:05:35 UTC
Note, I've reported this issue due https://pagure.io/cloud-sig/issue/289

Comment 4 Kevin Fenzi 2018-06-28 15:51:58 UTC
(In reply to Dusty Mabe from comment #2)
> I'm thinking we should just add in NetworkManager in the cloud base image
> since that's what the rest of Fedora uses.

Yeah, I think NetworkManager would be fine too, although some might complain that it leaves a process running taking up ram.

Comment 5 Bruno Goncalves 2018-07-12 08:06:53 UTC
I'm just wondering if there is any update about this issue as Fedora-Cloud-Base-Rawhide-20180711.n.0 still does not work.

Comment 6 Dusty Mabe 2018-07-12 13:20:20 UTC
I have asked jdoss to open a PR to pagure.io/fedora-kickstarts on master branch to add NM to the cloud base image.

please ping back in a week.

Comment 7 Bruno Goncalves 2018-07-16 10:42:09 UTC
Thanks for the PRs, I do not know if it is related to it or not, but the current rawhide qcow2 is not booting at all.

With Fedora-Cloud-Base-Rawhide-20180711.n.0.x86_64.qcow2 I see it booting up.

but on Fedora-Cloud-Base-Rawhide-20180714.n.0.x86_64.qcow2 I do not see any message of boot process.

Comment 8 Bruno Goncalves 2018-07-20 07:07:27 UTC
I've just tried Fedora-Cloud-Base-Rawhide-20180719.n.0.x86_64.qcow2 and it works for me. Do you think this BZ can be closed?

http://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20180719.n.0/compose/Cloud/x86_64/images/Fedora-Cloud-Base-Rawhide-20180719.n.0.x86_64.qcow2

Comment 9 Dusty Mabe 2018-07-20 13:08:08 UTC
sure! :)