Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 1596041

Summary: Failed to run virt-who-0.22.2-5 with error "ImportError: No module named libvirt"
Product: Red Hat Enterprise Linux 7 Reporter: Eko <hsun>
Component: virt-whoAssignee: William Poteat <wpoteat>
Status: CLOSED ERRATA QA Contact: Eko <hsun>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7.6CC: csnyder, jhnidek, khowell, shyan, wpinheir, wpoteat, yanpliu, yuefliu
Target Milestone: rcKeywords: EasyFix, Triaged
Target Release: 7.7   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 10:47:49 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Kevin Howell 2018-06-28 14:31:14 UTC
Dev, let's just add requirement for python-libvirt.

Possible future work could make the dependency optional (big factor is does libvirt automatically install python-libvirt?) [use case: customer does want to use libvirt w/ virt-who, they should be able to use both by install libvirt and virt-who packages only]

Comment 3 Eko 2018-08-17 03:25:43 UTC
Hi Dev, 
Please create the new virt-who package for rhel7.6 next compose, thus we can test and verify it early, thanks.

Comment 8 errata-xmlrpc 2018-10-30 10:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3169