Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159573

Summary: Init hangs when boot option 'rhgb'is not passed at grub boot
Product: [Fedora] Fedora Reporter: Gavin Graham <gavindi>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: davej, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-28 19:21:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gavin Graham 2005-06-05 03:26:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
If you remove 'rhgb' from you kernel options in grub, initscripts will hange at:
Initializing Hardware  usb storage audio *HANG*

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Remove rhgb from the kernel options
2. Boom

  

Actual Results:  Init hangs

Expected Results:  Boot process should continue without rhgb

Additional info:

Comment 1 Gavin Graham 2005-06-05 03:28:32 UTC
*** Bug 159574 has been marked as a duplicate of this bug. ***

Comment 2 Gavin Graham 2005-06-05 20:21:04 UTC
Correction:
Initializing Hardware  network storage audio *HANG*

A little inconsisant as I have now had this happen even with the rhgb option in
the kernel params. In this case I had to change run levels in kernel params to
get around the hang.

Comment 3 Bill Nottingham 2005-06-06 05:44:52 UTC
If you add -x to the #!/bin/bash line of /etc/rc.sysinit, where does it hang?

Comment 4 Gavin Graham 2005-06-06 09:15:33 UTC
That's a good idea, here is the output:

for module in '$other'
load-module uhci-hcd
LC_ALL=C
fgrep -xq uhci-hcd /etc/hotplug/blacklist
modprobe uhci-hcd

This obviously tranlates into the following part of rc.sysinit:
load_module () {
        LC_ALL=C fgrep -xq "$1" /etc/hotplug/blacklist 2>/dev/null || modprobe
$1 >/dev/null 2>&1
}

So it seems that this is kernel related and not initscripts related.
I have tried removing USB devices one-by-one and it hasn't made a difference.
My motherboard is an Aopen AX4C Max-II (Intel 875P & ICH5R chipsets).

This has only started happening since the 136X kernel builds. I am unsure of how
widespread this affect could be. How do you want to proceed with this?


Comment 5 Bill Nottingham 2005-06-06 16:02:47 UTC
Assigning to kernel for now.

Comment 6 Gavin Graham 2005-06-23 21:35:44 UTC
Seems to have have something to do with load the USB kernel modules. If I hold
down the shift key on my USB keyboard while these modules are loading, It will
always successfully load the module and continue booting.
If I do not hold down the shift key, there is a 50/50 change that it will hang
at that point.
I have installed the Rawhide 2.6.12 kernel and it *SEEMS* that this problem has
gone away.


Comment 7 Dave Jones 2005-06-27 23:17:23 UTC
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.

Comment 8 Dave Jones 2005-07-15 21:08:16 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 9 Gavin Graham 2005-07-16 04:55:17 UTC
I have not changed that config files but I have installed the new kernel as
directed. The problem no longer exists.
I will leave for you to close if you are happy to do so.