Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159206

Summary: Yum fails to update biarch glibc
Product: [Fedora] Fedora Reporter: David Woodhouse <dwmw2>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: katzj, marcelo
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-31 16:15:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Woodhouse 2005-05-31 15:47:30 UTC
fish /fish/redhat/rawhide-ppc # yum update
Setting up Update Process
Setting up repositories
audit                     100% |=========================|  951 B    00:00
development               100% |=========================| 1.1 kB    00:00
livna-stable              100% |=========================|  951 B    00:00
fc3-updates               100% |=========================|  951 B    00:00
base                      100% |=========================|  951 B    00:00
extras-devel              100% |=========================| 1.1 kB    00:00
livna-testing             100% |=========================|  951 B    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kakasi-devel.ppc 0:2.3.4-20 set to be updated
---> Package perl-Text-Kakasi.ppc 0:2.04-1 set to be updated
---> Package glibc-profile.ppc 0:2.3.5-10 set to be updated
---> Package recode.ppc 0:3.6-17 set to be updated
---> Package SDL_mixer-devel.ppc 0:1.2.5-7 set to be updated
---> Package glibc-common.ppc 0:2.3.5-10 set to be updated
---> Package glibc-headers.ppc 0:2.3.5-10 set to be updated
---> Package flim.noarch 0:1.14.7-3 set to be updated
---> Package isdn4k-utils.ppc 0:3.2-28 set to be updated
---> Package isdn4k-utils-vboxgetty.ppc 0:3.2-28 set to be updated
---> Package namazu-cgi.ppc 0:2.0.14-3 set to be updated
---> Package gnu-crypto-jce-jdk1.4.noarch 0:2.0.1-1jpp_5fc set to be updated
---> Package namazu.ppc 0:2.0.14-3 set to be updated
---> Package xisdnload.ppc 0:3.2-28 set to be updated
---> Package SDL_image.ppc 0:1.2.3-9 set to be updated
---> Package xboard.ppc 0:4.2.7-9 set to be updated
---> Package gnome-applets.ppc 1:2.10.1-9 set to be updated
---> Package alsa-lib-devel.ppc 0:1.0.9rc4-2 set to be updated
---> Package mew-common.ppc 0:4.2-1 set to be updated
---> Package glibc.ppc 0:2.3.5-10 set to be updated
---> Package namazu-devel.ppc 0:2.0.14-3 set to be updated
---> Package xemacs-sumo-info.noarch 0:20050505-3 set to be updated
---> Package gnu-crypto-sasl-jdk1.4.noarch 0:2.0.1-1jpp_5fc set to be updated
---> Package libtabe-devel.ppc 0:0.2.6-14 set to be updated
---> Package recode-devel.ppc 0:3.6-17 set to be updated
---> Package kernel-doc.noarch 0:2.6.11-1.1366_FC4 set to be updated
---> Package mew.ppc 0:4.2-1 set to be updated
---> Package w3m-el-common.ppc 0:1.4.4-1 set to be updated
---> Package glibc-utils.ppc 0:2.3.5-10 set to be updated
---> Package screen.ppc 0:4.0.2-9 set to be updated
---> Package nfs-utils.ppc 0:1.0.7-8 set to be updated
---> Package alsa-lib.ppc 0:1.0.9rc4-2 set to be updated
---> Package SDL_image-devel.ppc 0:1.2.3-9 set to be updated
---> Package gnu-crypto.noarch 0:2.0.1-1jpp_5fc set to be updated
---> Package w3m-el.ppc 0:1.4.4-1 set to be updated
---> Package mew-xemacs.ppc 0:4.2-1 set to be updated
---> Package libtabe.ppc 0:0.2.6-14 set to be updated
---> Package kakasi-dict.ppc 0:2.3.4-20 set to be updated
---> Package isdn4k-utils-devel.ppc 0:3.2-28 set to be updated
---> Package nscd.ppc 0:2.3.5-10 set to be updated
---> Package kernel-devel.ppc 0:2.6.11-1.1366_FC4 set to be installed
---> Package SDL_mixer.ppc 0:1.2.5-7 set to be updated
---> Package jessie.noarch 0:1.0.0-8 set to be updated
---> Package kakasi.ppc 0:2.3.4-20 set to be updated
---> Package glibc-devel.ppc 0:2.3.5-10 set to be updated
---> Package iptraf.ppc 0:2.7.0-15 set to be updated
--> Running transaction check
--> Processing Dependency: glibc-headers = 2.3.5-9 for package: glibc-devel
--> Processing Dependency: glibc-common = 2.3.5-9 for package: glibc
Traceback (most recent call last):
  File "/usr/bin/yum", line 15, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 113, in main
    (result, resultmsgs) = base.buildTransaction()
  File "__init__.py", line 319, in buildTransaction
  File "depsolve.py", line 210, in resolveDeps
  File "depsolve.py", line 341, in _processReq
  File "depsolve.py", line 453, in _requiringFromInstalled
  File "sqlitesack.py", line 413, in returnNewestByNameArch
repomd.mdErrors.PackageSackError: No Package Matching glibc.ppc64

It lies. There really is a PPC64 glibc package available.

Comment 1 David Woodhouse 2005-05-31 16:15:14 UTC
Fixed by correcting /etc/rpm/platform to 'ppc64-redhat-linux'. Thanks, Paul.

Comment 2 Karsten Wade 2005-08-16 19:13:24 UTC
*** Bug 165937 has been marked as a duplicate of this bug. ***