Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159163

Summary: local variable used before set
Product: [Fedora] Fedora Reporter: David Binderman <dcb314>
Component: gnome-appletsAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED UPSTREAM QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-08-31 20:26:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Binderman 2005-05-30 21:53:34 UTC
Description of problem:

I just tried to compile package gnome-applets-2.10.1-9 from Redhat Fedora
Core development tree with the most excellent Intel C compiler.

The compiler said

applet.c(150): remark #592: variable "file" is used before its value is set

The source code is

	g_warning (G_STRLOC ": cannot open %s: %s", file, error->message);

Suggest initialise local variable "file" before first use.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2005-08-31 18:56:33 UTC
Hi,

It looks like the code in question is dead-code that will never be run. 
Nevertheless, could you file this upstream?

Comment 2 David Binderman 2005-08-31 19:17:16 UTC
>Nevertheless, could you file this upstream?

Sorry, no. 

This package got deleted from my computer months ago.

If you have the package immediately to hand, maybe you might like
to submit this bug upstream ?

Comment 3 Ray Strode [halfline] 2005-08-31 19:50:57 UTC
Sure.

Comment 4 Ray Strode [halfline] 2005-08-31 20:26:48 UTC
Hi,

I've filed the bug upstream here:

http://bugzilla.gnome.org/show_bug.cgi?id=314985

You can track its progress there, if you like.