Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 159043

Summary: I2O grub install fails
Product: Red Hat Enterprise Linux 4 Reporter: Warren Togami <wtogami>
Component: grubAssignee: Peter Jones <pjones>
Status: CLOSED ERRATA QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.0CC: administrator, katzj, laroche, markus.lidel
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2005-703 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-05 16:37:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 158158    
Bug Blocks: 156322    

Description Warren Togami 2005-05-27 23:31:45 UTC
+++ This bug was initially created as a clone of Bug #158158 +++

RHEL4-U1-re0525.0 fails I2O grub install.  This is the same problem as Bug
#158158 from Fedora.  ALT-F5 says this after installation
is complete:

grub> root(hd0,0)
 Filesystem type is ext2fs, partition type 0x83
grub> install /grub/stage1 d (hd0) /grub/stage2 p (hd0,0)/grub/grub.conf

Error 22: No such partition

Bug #158158 found that grub had incorrect i2o partition detection code, using
cciss-like device names when /dev/i2o/* devices are really more like IDE device
names.  The replacement patch in that bug solves this issue.

Impact: RHEL4 installs on I2O controllers (many Adaptec and other brand of SCSI
RAID, still selling today), but grub fails to install because it cannot find the
device from Anaconda.

Mitigating Workaround: If we do not patch grub, users can boot into rescue mode,
chroot into the /mnt/sysimage and "grub-install /dev/i2o/hda" in order to
install grub.

We should consider this for RHEL4 because the fix is well understood and does
not affect non-I2O devices.

Comment 3 Warren Togami 2005-05-28 05:15:46 UTC
http://i2o.shadowconnect.com/rhel.php
Procedure to workaround this problem and install grub in Rescue Mode is detailed
at this page.

Comment 7 Warren Togami 2005-07-15 09:14:23 UTC
*** Bug 158784 has been marked as a duplicate of this bug. ***

Comment 11 Red Hat Bugzilla 2005-10-05 16:37:28 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-703.html