Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158909

Summary: RFE: Checkbox for "autostart" for services
Product: [Retired] Red Hat Cluster Suite Reporter: Lon Hohberger <lhh>
Component: redhat-config-clusterAssignee: Jim Parsons <jparsons>
Status: CLOSED NEXTRELEASE QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: cluster-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-06-07 22:27:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lon Hohberger 2005-05-26 18:48:19 UTC
Description of problem:

In RHCS3, service state was persisted across quorum transitions because it wrote
the states to stable storage.  In RHCS4, we have no such luxury.  The service
states are distributed, and are zapped when quorum is lost.

So, I added an "autostart" (default=1) to services at some point along the way.
 This allows services to automatically start when quorum is achieved and/or when
rgmanager starts.

When autostart is explicitly set to 0, the service will not automatically start
when the cluster is ready... instead, the administrator will have to enable it.

As a UI thing, I would think this is a check box which defaults to "checked".

Comment 1 Jim Parsons 2005-06-06 14:59:18 UTC
In 0.9.70-1.0

Comment 2 Corey Marthaler 2005-06-07 22:27:22 UTC
check box has been added.