Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158571

Summary: Scratched sound output
Product: [Fedora] Fedora Reporter: Enrico Scholz <rh-bugzilla>
Component: esoundAssignee: John (J5) Palmieri <johnp>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: ernstp, henryl, jkeck, mhw, scop
Target Milestone: ---Keywords: Patch
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: FC5 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-22 02:08:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Update to 0.2.36 none

Description Enrico Scholz 2005-05-23 17:44:04 UTC
Description of problem:

Recent esound/alsa/<whatever> produces broken (overdrived??) sound. E.g.

| esdplay /usr/share/sounds/KDE_Startup_new.wav
| esdplay /usr/share/system-config-soundcard/sound-sample.wav

sounds broken. Using the OSS layer sounds fine:

| play /usr/share/sounds/KDE_Startup_new.wav


Same happens when e.g. playing songs in XMMS; with the esd output plugin they
sound broken, while ALSA or OSS output are fine.

All this happened after a big system upgrade from FC3.90 to recent rawhide;
things were fine before the upgrade.


Version-Release number of selected component (if applicable):

esound-0.2.35-4
alsa-lib-1.0.9rc2-5

snd_intel8x0 on an ASUS P4C800-E


How reproducible:

100%

Comment 1 Enrico Scholz 2005-05-23 19:23:45 UTC
Disabling 'dmix' in my ~/.asoundrc with


| pcm.!default {
|         type hw
|         card ICH5
|         device 0
| }

makes sound work again.


Comment 2 bperkins 2005-06-18 22:21:26 UTC
Same report here



Also using snd_intel8x0 on an IBM Thinkpad R32.
This is probably an ALSA problem.

This ~/.asoundrc worked for me.


pcm.!default {
         type hw
         card 0
         device 0
 }

Comment 3 Henry Leung 2005-07-08 12:34:31 UTC
The problem can also be solved by download and install esound 0.2.36.
I'm not sure whether the problem is caused by esound 0.2.35, or by the patches
that fedora applied. Anyway the problem was fixed after applied the above update.

I suggest that fedora should treat this problem as critical, as this impact
GNOME and all applications that rely on esound.

Comment 4 Ville Skyttä 2005-07-13 18:58:57 UTC
This is particularly annoying for me with SDL applications (er, games): SDL in 
FC has been     
patched to prefer arts, then esound, then oss, then alsa.  Now, I run KDE, but     
cannot use arts because of the delay it introduces to eg. SDL games' sounds.      
So, I get esound, which produces distorted sound.  I "fixed" it for SDL by 
setting SDL_AUDIODRIVER=alsa ("dsp" works too) in the environment. 
     
Anyway, comment 3 seconded, an update would be nice.  This is IBM ThinkPad    
A30p, snd_intel8x0 too.  Updating to 0.2.36 fixes it and doesn't appear to    
break anything (running on FC4).  Will attach the patch I used to update. 

Comment 5 Ville Skyttä 2005-07-13 19:01:14 UTC
Created attachment 116716 [details]
Update to 0.2.36

Comment 6 John Conroy 2005-07-29 08:36:58 UTC
I had similar issues and posted a workaround in Comment #2 of Bug #140999.

Comment 7 Ville Skyttä 2005-07-31 14:48:03 UTC
That workaround doesn't appear to help here, but updating to 0.2.36 does. 

Comment 8 Mark Wilkinson 2005-08-03 14:23:19 UTC
Just a further data point: I'm seeing (or hearing!) the same problem on FC4
running on a Dell Latitude D600. The .asoundrc workaround works for me. Haven't
tried building my own 0.2.36 package yet.

Comment 9 Dan Hensley 2005-10-25 02:28:16 UTC
This affects my motherboard (Gigabyte K8N Pro-SLI with onboard ALC850).  Both
the solution in comment #2 of this bug and comment #6 worked for me.  I also
second comment #3.

Comment 10 John (J5) Palmieri 2005-10-26 20:40:28 UTC
esound has been 0.2.36 since July, I'm not sure why the bug isn't closed. Am I
missing something or are people still seeing this issue in 0.2.36?

Comment 11 Ville Skyttä 2005-10-26 20:58:00 UTC
FWIW, FC4 is still at 0.2.35, and affected. 

Comment 12 John (J5) Palmieri 2005-10-26 22:31:08 UTC
Ah, ok.  Switching version.

Comment 13 John (J5) Palmieri 2005-10-26 22:46:16 UTC
Building 0.2.36-0.fc4.1 as a release candidate.  Should be pushed soon.

Comment 14 Fedora Update System 2005-10-27 17:08:52 UTC
From User-Agent: XML-RPC

esound-0.2.36-0.fc4.1 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 15 Ville Skyttä 2005-10-27 18:18:53 UTC
0.2.36-0.fc4.1 seems to fix it here indeed.  Thanks! 

Comment 16 Dan Hensley 2005-10-28 17:58:05 UTC
0.2.36-0.fc4.1 does NOT fix it here.  I have left the esd.conf file alone
(unlike the suggestion in #140999).  I have a Gigabyte K8N Pro-SLI and AMD 64 X2
3800+ (running in non-smp mode due to the numerous problems with the smp
kernel).  The fix suggested in Comment #2 did fix the problem with the 0.2.35
package.  I will reapply it again to see if that fixes it for 0.2.36.

Comment 17 Graham Evans 2005-11-14 11:02:23 UTC
Comment #2 method DID work for me on x86_64.  Upgrade to 0.2.36 DID NOT work. 
Also suggestion on 140999 about forcing a changed sampling rate DID NOT work.

Comment 18 Bill Nottingham 2006-09-22 02:08:39 UTC
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Comment 19 John Thacker 2006-10-31 20:04:11 UTC
*** Bug 140999 has been marked as a duplicate of this bug. ***