Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158562

Summary: missing areca raid controller driver
Product: [Fedora] Fedora Reporter: Tim <ttaranov>
Component: kernelAssignee: Dave Jones <davej>
Status: CLOSED UPSTREAM QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: pfrields, tibbs, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-23 23:04:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
areca driver patch from Morton's mm patch tree none

Description Tim 2005-05-23 15:46:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Description of problem:
Is it possible to add driver for Areca Raid controller to FC4? There is already a patch out there for the 2.6.12 kernel that is verified and certified by vendor. I tried it using it with 2.6.11 kernel that FC4 uses and it works just fine. The url to the patch (it's currently part of Andrew Morton's mm patch tree - but can be applied separately, without any other patches that are part of the mm tree) is 

http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.12-rc4/2.6.12-rc4-mm2/broken-out/areca-raid-linux-scsi-driver.patch

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install FC4
2. Areca Raid controller is not recognized untill the kernel is rebuild with the 
3. Rebuild the kernel with the patch - and Areca controller is recognized just fine
  

Additional info:

Comment 1 Tim 2005-05-23 15:51:30 UTC
Created attachment 114721 [details]
areca driver patch from Morton's mm patch tree

The patch can be found under 

http://www.kernel.org/pub/linux/kernel/people/akpm/patches/2.6/2.6.12-rc4/2.6.12-rc4-mm2/broken-out/areca-raid-linux-scsi-driver.patch

Comment 2 Jason Tibbitts 2005-05-23 16:49:54 UTC
I agree that it would be nice to have; I have many systems with all storage on a
RAID controller and I am limited to 3ware cards because I won't use anything
that can't be seen from a rescue disk.  I also understand about drifting from
upstream, but given that this driver has very low impact and will most likely
make it into 2.6.13, I wonder if an exception could be made so that it gets onto
the FC4 boot media.

Perhaps Arjan could comment about possible stability impact, since he worked on
the driver.

Comment 3 Dave Jones 2005-05-23 23:04:45 UTC
After discussion with the scsi maintainer, this driver still needs some work
before its ready for inclusion upstream. Being in -mm is no holy-grail to
stability sadly.


Comment 4 Tim 2005-05-24 01:10:06 UTC
oh, well - that was worth a try. I guess now I'll need to be hacking my own
kernel together with every upgrade - what a pain.