Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158493

Summary: openoffice package dependency bug
Product: [Fedora] Fedora Reporter: Jonathan S. Shapiro <shap>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: hablack, jbourne
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-28 08:24:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 136450    

Description Jonathan S. Shapiro 2005-05-22 23:51:42 UTC
Since when does openoffice.org depend on libjawt?

Or if for some reason it must, why isn't the correct version of libjawt pushed
into the devel tree?

openoffice.org.i286 1:1.9.104-1

Comment 1 Hal Black 2005-05-24 16:15:37 UTC
I'm guessing this is the same bug that prevents yum from updating openoffice.org:

---> Package openoffice.org-core.i386 1:1.9.104-1 set to be updated

Error: Missing Dependency: libjawt.so.6 is needed by package openoffice.org-core


Comment 2 James Bourne 2005-05-24 18:23:48 UTC
libjawt.so.6.0.0 has been renamed to libgcjawt.so.6.0.0 in libgcj-4.0.0-8.

openoffice.org needs to be relinked.

Comment 3 Jonathan S. Shapiro 2005-05-24 18:53:06 UTC
Ahh. This explains why the update didn't go through even though I actually have
libjawt installed -- the libgcj upgrade (which is trying to happen at the same
time) is planning to whack that.

Comment 4 Jonathan S. Shapiro 2005-05-24 20:47:40 UTC
Wait a minute. Is libjawt new in this release? If not, won't renaming it break
dynamic link dependencies from other applications in addition to OpenOffice?

Comment 5 Jeremy Katz 2005-05-24 21:11:33 UTC
It's new in this release.  OOo got rebuilt this morning and should be in
tomorrow's rawhide.

Comment 6 Jonathan S. Shapiro 2005-05-24 22:58:37 UTC
Cool. And thank you.