Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158418

Summary: SIGSEGV fault in ccsd after starting rgmanager
Product: [Retired] Red Hat Cluster Suite Reporter: Henry Harris <henry.harris>
Component: ccsAssignee: Jonathan Earl Brassow <jbrassow>
Status: CLOSED NEXTRELEASE QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 4CC: cluster-maint, lhh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-24 20:38:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Henry Harris 2005-05-22 04:09:06 UTC
Description of problem: This problem occurred after creating a new cluster.conf
file and then starting rgmanager.  Lon H. was on the phone with me helping me
work through some other issues when this occurred so he may remember better than
I do exactly what the sequence of events was.  I have e-mailed the
/var/log/messages output to Lon separately.


Version-Release number of selected component (if applicable):


How reproducible:
Only seen once.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jonathan Earl Brassow 2005-05-24 20:38:21 UTC
- fix segfault

# Seg fault could be achieved with:
$> ccsd; ccs_test get 0 //@name

While the code was checking if the desc was valid, it was not checking
if the desc block had been created.