Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158393

Summary: printf problem
Product: [Fedora] Fedora Reporter: David Binderman <dcb314>
Component: amandaAssignee: Jay Fenlason <fenlason>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: jfeeney
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-18 16:03:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Binderman 2005-05-21 14:30:01 UTC
Description of problem:

I just tried to compile package amanda-2.4.5-2 from Redhat
Fedora Core development tree with the most excellent Intel C
compiler.

The compiler said

sendsize.c(559): warning #267: the format string requires additional arguments

The source code is

            dbprintf(("%s: Can't use CALCSIZE for samba estimate: %s %s\n",
                      est->amname, est->dirname));

Three %s specifiers, only two trailing parameters. Suggest code re work.

The gcc compiler should also detect this fault, when compile flag -Wall
is used.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Fenlason 2005-08-31 14:38:16 UTC
*** Bug 167171 has been marked as a duplicate of this bug. ***