Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158294

Summary: e-mail merge does not work.
Product: [Fedora] Fedora Reporter: Douglas Furlong <bugzilla_rhn>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.9.114-2 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-07 12:36:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Douglas Furlong 2005-05-20 12:11:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.8) Gecko/20050512 Fedora/1.0.4-2 Firefox/1.0.4

Description of problem:
When using the Mail Merge Wizard, the E-mail message option is grayed out.

There is a comment stating that Open Office was unable to find the Java Mail connection, and points me to Sun's website to find out more.

Version-Release number of selected component (if applicable):
openoffice.org-1.9.100-1, java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh,  classpathx-mail-1.0-3jpp_1fc

How reproducible:
Always

Steps to Reproduce:
1. Go to Mail Merge Wizard in Open Office
2. Try to select the e-mail mail merge
3.
  

Actual Results:  Option is grayed out, and unselectable

Expected Results:  I should be able to select the e-mail option for mail merge.

Additional info:

Package version

openoffice.org-1.9.100-1, 
java-1.4.2-gcj-compat-1.4.2.0-40jpp_18rh,  
classpathx-mail-1.0-3jpp_1fc

I have tried this on both ppc and i386

Comment 1 Caolan McNamara 2005-06-02 13:56:21 UTC
indeed, interesting. Try editing
.openoffice.org2.0/user/registry/data/org/openoffice/Office/Writer.xcu and
change the "false" under EMailSupported to "true" and restart ooo and see how
much further you get .

Comment 2 Caolan McNamara 2005-06-02 14:40:16 UTC
Ack!, http://user-faq.openoffice.org/servlets/ReadMsg?list=authors&msgNo=7907

We need to implement a mail::XMailService to get mail working

Comment 3 Douglas Furlong 2005-06-02 20:26:15 UTC
Doh.

Does that mean you do not need me to try that fix you've mentioned?

I'm getting the feeling that this feature may be a while coming :\

Comment 4 Caolan McNamara 2005-07-05 13:34:25 UTC
Might not be too long, I've started and implementation, and it doesn't look
*too* hard. http://blogs.linux.ie/caolan/2005/07/05/email-mailmerge/

Comment 5 Caolan McNamara 2005-07-06 12:26:35 UTC
Submitted implementation upstream as
http://www.openoffice.org/issues/show_bug.cgi?id=51638
I'll build it for fedora now and see how it goes.

Comment 6 Caolan McNamara 2005-07-07 12:36:45 UTC
Available in rawhide 1.9.114-2

Comment 7 Douglas Furlong 2005-07-17 09:11:33 UTC
Heyah Caolan.

I've tried the latest build of open office from raw hide, and classpathx-mail
from main, and the option is still grayed out.

Versions...

[root@localhost ~]# rpm -qa | grep openoffice.org
openoffice.org-core-1.9.117-1.2.0.fc5
openoffice.org-math-1.9.117-1.2.0.fc5
openoffice.org-graphicfilter-1.9.117-1.2.0.fc5
openoffice.org-pyuno-1.9.117-1.2.0.fc5
openoffice.org-draw-1.9.117-1.2.0.fc5
openoffice.org-impress-1.9.117-1.2.0.fc5
openoffice.org-writer-1.9.117-1.2.0.fc5
openoffice.org-calc-1.9.117-1.2.0.fc5
openoffice.org-xsltfilter-1.9.117-1.2.0.fc5
[root@localhost ~]# rpm -qa | grep classpathx
classpathx-jaf-1.0-2jpp_3fc
classpathx-mail-1.0-3jpp_1fc


I know that it is not version 114 would that be a problem?

Comment 8 Caolan McNamara 2005-07-17 11:12:59 UTC
you don't need any classpathx stuff, just what you have installed. This is
probably because you ran it in the old OOo which didn't provide it. Try removing
your ~/.openoffice.org* directories and running it again and see if it makes it
become enabled ?

Comment 9 Douglas Furlong 2005-07-17 12:47:48 UTC
Deleting that directory made the difference, it is no longer grayed out.

I don't have time to test this just yet, but will try to some time this week.