Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158213

Summary: bad dialog on CD insertion
Product: [Fedora] Fedora Reporter: Bill Nottingham <notting>
Component: gnome-volume-managerAssignee: John (J5) Palmieri <johnp>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: davidz, havardda-dev, jkeck, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-10-14 03:04:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 136451    

Description Bill Nottingham 2005-05-19 16:58:37 UTC
I forget where this lives these days, please reassign.

Insert a CD with a autorun file of:

...
#!/bin/sh
#
# Autorun script for Red Hat Linux
# Copyright (c) 1999-2002 Red Hat, Inc.

dir=$(echo $0 |sed 's/autorun//')
cd $dir
tree=$(pwd)

# Change directories so we can unmount the CD-ROM Drive
cd /
exec /usr/bin/redhat-cdinstall-helper $tree
...

Pops up a dialog that says:

 Run command from inserted media?

 Do you want to run the file "%s?"

That can't be right.

Comment 1 David Zeuthen 2005-05-22 16:22:05 UTC
This would be in g-v-m so I'm reassigning to johnp. I'm not sure why you think
this is a bug? The wording perhaps?

Note we have "Auto-run programs on new drives and media" off by default, so I
think that's why you get the dialog.

Comment 2 Bill Nottingham 2005-05-23 04:20:24 UTC
The bug is that the message includes a literal '%s'. That can't be right.

Comment 3 David Zeuthen 2005-05-23 04:39:55 UTC
No, that can't be right.

Comment 4 John (J5) Palmieri 2005-05-25 14:32:29 UTC
*** Bug 158730 has been marked as a duplicate of this bug. ***