Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158151

Summary: pygtk2-demo not executable
Product: [Fedora] Fedora Reporter: Wei-Lun Chao <bluebat>
Component: pygtk2Assignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: rawhideCC: 13640887
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-09-24 01:47:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Wei-Lun Chao 2005-05-19 06:02:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:


Version-Release number of selected component (if applicable):
pygtk2-2.6.0-2

How reproducible:
Always

Steps to Reproduce:
1.ls -l /usr/bin/pygtk2-demo

Actual Results:  -rw-r--r--

Expected Results:  -rwxr-xr-x


Additional info:

Comment 1 Wei-Lun Chao 2005-10-17 02:54:47 UTC
the file name has been renamed to /usr/bin/pygtk-demo,
but still not executable.

Comment 2 Wei-Lun Chao 2006-02-03 01:41:50 UTC
plus some error:

bash: /usr/bin/pygtk-demo: line 5: syntax error near unexpected token `('
bash: /usr/bin/pygtk-demo: line 5: `pygtklibdir = os.path.join("/usr/lib",
"pygtk", "2.0")'


Comment 3 Albert Strasheim 2006-06-06 11:14:17 UTC
As far as I can see, this file now lives here:

/usr/share/doc/pygtk2-1.99.16/examples/pygtk-demo/pygtk-demo.py

Comment 4 Matthew Barnes 2006-09-24 01:47:17 UTC
This seems to be fixed in the latest Rawhide release.  Closing this bug.

ls -l /usr/share/doc/pygtk2-2.10.1/examples/pygtk-demo/pygtk-demo.py
-rwxr-xr-x 1 root root 11106 Oct  1  2004 .../pygtk-demo.py

pygtk2-2.10.1-4.fc6