Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 158148

Summary: exclude doesn't
Product: [Fedora] Fedora Reporter: Gregory Maxwell <gmaxwell>
Component: yumAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3CC: katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-19 05:20:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Gregory Maxwell 2005-05-19 05:17:28 UTC
Description of problem:

Yum is configured to exclude kernel updates and several other RPMS on some of my
FC3 systems because I am using LVM on DMCrypt and require a custom ramdisk to
boot.  Yum upgrade of the kernel without supervision makes my systems unbootable.

The exclusion normally works, but if another package appears in updates that I
am not excluding which contains a claimed dependency on a newer kernel, the
kernel gets picked up to satisfy the dependency. 

Version-Release number of selected component (if applicable):

yum-2.2.0-0.fc3

How reproducible:

It happens every time something depends on a newer kernel.

Steps to Reproduce:
1.set yum to exclude=kernel*
2.run regular updates until something depends on a newer kernel.
3.recieve new kernel inspite of configuration 
  
Actual results:

New kernel is installed

Expected results:

New kernel is not installed, or possibly yum update fails due to dependencies
that can not be met.

Additional info:

#/etc/yum.conf
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20
obsoletes=1
keepalive=1
gpgcheck=1
exclude=kernel*
exclude=mkinitrd-*
exclude=initscripts-*
exclude=cryptsetup*
# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

I would be glad to perform whatever tests are needed.

Comment 1 Seth Vidal 2005-05-19 05:20:38 UTC
You cannot have multiple exclude lines in a single section.

they overwrite each other, they do not append.

the above should be written as:
exclude=kernel* mkinitrd* initscripts* cryptsetup*