Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 157623

Summary: enhance font sub-system through fontconfig/pango migration
Product: [Fedora] Fedora Reporter: Lawrence Lim <llim>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: dcbw, eng-i18n-bugs, tools-bugs
Target Milestone: ---Keywords: FutureFeature, i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-07-14 09:43:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 157816    

Description Lawrence Lim 2005-05-13 08:02:56 UTC
Description of problem:
If user switch LE within GIMLET while using oowriter, oowriter is not aware of
the changes and the font is not updated. User is required to change the font
manually.

Version-Release number of selected component (if applicable):
OOo-1.9-100-1

How reproducible:
Always

Steps to Reproduce:
1.LANG=zh_TW.UTF-8 oowriter
2.observe the font used is AR PL Mingti2L Big5
3.in GIMLET, change to another say chinput  (Simplified Chinese)
4.observe the font again

  
Actual results:
Still using AR PL Mingti2L Big5

Expected results:
Should be using Simplified Chinese font, AR PL Sungtil GB

Additional info:

Comment 3 Caolan McNamara 2005-07-10 18:25:45 UTC
You want the font to change depending on the input setting ? Is it necessary now
that the fontconfig stuff is working for glyph substitution? Changing the font
depending on the input setting sounds a bit dodgy to me. Does anything else work
this way ?

Comment 4 Caolan McNamara 2005-07-14 09:43:52 UTC
Assuming that the problem is that we want it to *just work*, i think the
fontconfig stuff in 1.9.117-1 is pretty complete.